Argon One M.2 SSD not working

I use a Argon One M.2 case with a Raspberry Pi 4 (4GB). Standard settings no overclocking.

I can boot from SD Card with no issue but I am getting problems when trying to use the M.2-SSD

  1. Raspberry Pi Imager (on the Raspi 4) is not completing when I try to write a Raspi OS Image to the SSD.
  2. I am getting kernel panic when I write the image with Raspberry Pi Imager on a Windows10 PC and then try to boot from this SSD.
    I use the M.2 SATA board connected with a USB-A to USB-A on the windows PC.
    So far I tried the following:
  • I used a Kingston SA400M8 240GB SSD (B&M key) and a WD Blue SA510 1TB SSD (B&M key).
  • Used a standard Raspi Power supply (15W) and a Argon Power supply with 18W
  • I measured the voltage on the cap next to the M.2 boards USB connector and it shows 5.1V on the Raspi PS and 5.35V on the Argon PS,
  • I used a USB3 A to USB3 A cable (which I used to write the image on the Windows10 PC) to connect instead of the USB3 bridge
  • I tried both ways on the power jumper (default and always on)

All the above tests did not work.
What shall I do?

Best regards

What I found was the easiest way to copy a configured OS to the SSD was to boot without the USB jumper in place, then connect the jumper to the SSD in the M.2 and use the SD card copy utility. Also, have you configured the Pi to support booting direct from USB before it looks at the MicroSD slot?

Thanks Jon,
Meanwhile I used a powered USB hub and things are working.
So I think everything is configured correctly.
My doubt is that the power supply through the Raspi4 USB port is marginal. It would be great if the M.2 expansion board could be powered directly from the USB-C input.

@Ganymed can you please advise how did you fit the SA510 ? I am unable to… See my topic Argon One M.2 Case compatibility with WD Blue SA510