Unit not powering on at all

Hello, I am Backer #511.

I received my Argon Eon 40 today with a Pi4 4GB included.

I assembled it but when I press the button to power it on, nothing happens. If I power the Pi that was shipped with, by plugging a psu in its USB-C port, it power on as normal.

How should I proceed?

Comment: Here you can see that plugging on USB-C turns on the Pi.
0-02-05-f1e0415f8a5cf940e13ee43a576974dcea06885904aeea5ab6a03410b91da9d2_1f99607c0321d3

PS: It won’t let me attach more photos.

HI nsarant,

can you help check if the attachment to the plug is attach properly. We have reported issue of loose connection causing the PSU not to provide power. Would suggest removing the end of the plug and attach it again. If it is still not working, can contact our support at cs@argon40.com to arrange a replacement of the PSU once our warehouse resume operation in mid feb.

Hello,

Thank you very much for the answer.

I have tried what you proposed and it still doesn’t power up. Alright I will try to get my hands on another PSU next week then. I want to make sure that it’s not something about the motherboard.

Edit: After trying another PSU 12V 2.5A (from another machine) it got powered on so it is a faulty PSU. Thank you for the help.

1 Like

I have a similar issue. The FAN spins and the OLED flashes with the logo, but the PI does not power on.

The PI does work with its USB-C power brick.

Mine died after about a day. I appear to have gotten a faulty PSU as well. :frowning:

I’ve sent a message to customer support.