Remote does not work with LibreElec latest

I have spent the last three weeks working on innumerable options and none work. It looks like the Argon Remote does not work with LibreElec. I have worked through examples such as: Argon ONE and Argon Remote on latest LibreELEC fixed

The root cause looks like the move to Python 3 has broken the Argon driver.

Can anyone confirm if they have their remote working with LibreElec 11 and if yes how they got it to do so?

Bump. Has anyone gotten their case and remote to work with Libreelec latest?

[EDIT: typo]

1 Like

Still working on this with no success. Can somebody from Argon chime in?

1 Like

Bump again.


1 Like

Hello, we are actively working on updating the script to ensure compatibility with the latest OS versions (Raspbian, LibreELEC etc.) Your patience is greatly appreciated.


This is good to see. Do you have a rough ETA for a soltion?


Another bump on this - come on guys, pull your finger out! :rofl:

1 Like

I’d like to know more about when this might be available as well. You guys made the best case with IR functionality and this remote is holding it back.

If you are using LibreELEC Version 11.0.3 I will give you procedure to setup the ArgonForty Device Configuration

The Time/Date should be updated.

  1. Go to SETTINGS / Interface / Regional / Timezone country / Timezone to set the regional timezone

  2. Go to SETTINGS / LibreELEC / Connections to set the wifi connection

  3. Go to SETTINGS / LibreELEC / Network / NTP Servers / Timeserver #1 Timeserver #2 Timeserver #3 (you can have other timeserver that fits you)

  4. Go to Add-ons/ Install from repository / All repositories / Program add-ons / Raspberry Pi Tools (also System Tools)

  5. Prepare a USB Thumb drive with file by downloading

  6. Go to SETTINGS / SYSTEM / Add-ons / General and enable “Unknown Sources”

  7. Insert Thumb drive with Argon Forty Remote Add-on Zip file

  8. go back to Home / Add-ons click “Install from zip file”

  9. Select the file
    Proper installation is indicated when you see the Raspberry Pi Tools, System Tools and Argon Forty Device Configuration icons in the Program add-ons.
    After installing correctly (refer to the attached pictures), please follow these steps:

  10. Properly shut down the device using the LibreELEC GUI power button.

  11. Unplug and replug the power supply to implement the changes.

  12. Turn on the device using the Argon case button.

  13. Try rebooting by double-tapping the Argon case button.

  14. Attempt to shut down the device by long-pressing the Argon case button.
    Once you’ve completed these steps, you can use the Argon IR remote buttons. Ensure you activate the Argon case button first for the Argon IR remote to take effect.

I followed all of the above steps and the remote buttons still don’t work inside of Kodi. The only thing I can get to work is the power on/off button. Navigation, Enter, Home, Menu, Back, Volume UP/Down are still doing absolutely nothing.

I suspect that you have possibly misunderstood the issue. The power button on the case is working fine with LibreELEC 11.0.3 it’s the IR remote that we’re having issues with. The remote isn’t doing anything with Kodi.

Created an account so I could chime in here. I purchased the Argon One, M.2 add-on and the IR remote back in 2021. I have been patiently waiting for them to update their IR remote driver ever since Kodi/LibreElec update broke compatibility with the current software.
The lack of updates from Argon had left a bad taste in my mouth and I have since stayed away from their products. However, if the November post from the Argon rep is true, then all would be redeemed as I would be able to use this nice piece of kit again.
But until that update becomes available, I do not recommend this device and warn others to stay away until Argon update their IR driver.

Bump. Any way we can get a resolution on this issue?

If you want to use the Argon IR control with LE11 or LE12, you can attempt to use the updated version 0.0.9a of the Add-on from above. It includes the needed argon.lircd.conf file and place it as /storage/.config/lircd.conf. Additional it activates the module for Argon One IR sensor at pin 23.

Sometimes the needed changes at /flash/config.txt are skipped during the Add-On installation because the file was changed manually by the user. Then you should check if these lines are there:

1 Like

You just solved this problem for me. I’ve been banging my head against this issue for 2 days straight, tried every solution I could think of, and combed through forums as far and wide as I could search. Thank you from the bottom of my heart for putting that together. Argon should hire you, or compensate you for making their product actually usable. Their default scripts and zip files that the standard instructions lead to still haven’t been updated, and they leave you with a non-functional IR-remote. You solved this for free in February, it is now four months later and the official scripts and/or downloadable zip files still don’t have similar fixes incorporated into them. I really hope the ArgonForty team will address this / fix it sooner than later, so that their future customers won’t have to go through what I have trying to fix this.

1 Like