No video/audio from Argon V3 nvme case

Just got a RPI5 and an Argon v3 NVME case.
RPI 5 works fine with minihdmi to hdmi cable.
When using the Argon V3 bought with conversion to full size hdmi, I can only get image on RPI splash screen if I don’t have a storage media with OS attached. If I have any os (Kodi, Raspbian, Batocera) everything stays black forever (probably because it boots correctly)?

What is the reason? Does this daughterboard not support normal resolutions and is therefore useless?

The full size HDMI cables works fine with my other devices.

Any help will be appreciated

I woud suggest to make sure that the daughter is push in properly. Possible reason is board not fully connected.

Thanks for the suggestion, but I assure you that it is as tight as can be. I have try connecting and reconnecting it more times. It is not as no image will come - but only the splash screen can be viewed. I am almost certain that it does not convert the signal for higher resolutions correctly.

Both hdmi have no output? If you have access to a another.monitor would be try it.

Can also to try to add the following config.txt o test:

hdmi_force_hotplug=1
hdmi_drive=2

If things still dont work, please reach out to our customer service team, they should help resolve the issue.

I have tried 4 different monitors, the only one that can get ANY image at all is the first monitor I tried and it can ONLY get an image if I don’t boot anything and it has the default RPI splash screen. Any app or OS will only give a black screen. I have also tried entering hdmi_force_hotplug=1 and
hdmi_drive=2 in config.txt. It does not work :frowning:

Please contact our customer support, they should be able to send you a replacement.

Hello there.

I have the same exact issue. Non-working hdmi ports.
Everything else works. nvme, button, usb-c passthrough power and so on.

Hi there,

I have the same issue using the official Pi 5 power supply (27w). If I boot without a SD card, I get a boot screen with video (the HDMI ports function). If I boot with an SD card, I can access the device over network, but the HDMI ports do not function.

Thanks,

David

For HDMI issue, would suggest make sure that HDMI board is push in properly. It is a bit tight, so just push in gently, make sure that all the port are properly seated.

Same exact issue. The daughter board is pushed in as far as it will go. If I boot with no SD card and no SSD then I’ll get the raspberry pi boot screen. With an SD card the pi will boot, but no video. I can connect to the pi via ssh so I know it’s up and running. This is starting to appear to be an issue with either the quality of the Argon V3 as multiple people are having this issue.

Hi, can reach out to our customer service team, will try to help with the issue.

No solution so far. Tried to contact Argon, got a support ticket, but never heard back other than the automated email that they got the support request.

I received a replacement daughter board from Argon 40 today that is working great! So if you’re having this issue, reach out.

Note: the new board was labelled v1.4, whereas the one with issues was labelled v1.3.

1 Like

I reported what I believe to be the same issue, in No display out with One V3 NVME but I purchased the One V3 through a 3rd-party here in the UK (thepihut.com). Could you advise what I should do?

If it matters, my board is V1.3. Thanks!