Issue with Argon One M2 after soft shutdown and power cut

I just got my Argon One M2 case today and have been trying to figure out this issue. Everything works great on it, fans regulate, double-tap reboot works, etc. When I use the 3s long press for the soft reboot and power cut however, it shuts down as it should, but then when powered back up it loses all i2c communication. At this point, the fan stays on 100% and the power button loses all functionality until I pull the power completely. After which, everything works as it should again until I do another soft reboot.

When I run i2cdetect I get the output below
image

After a 3s press soft shutdown, I start getting this output
image

After pulling the USB-C power and returning it a few seconds later, i2cdetect gives me the top readout again. Has anyone run into this and have any idea what may cause it? The power button functionality was a major reason I chose this case and it’s basically functioning like an inline switch on the USB-C cable at this point.

I’m having exactly the same behavior, have you ever figured this out?

For me it started today, after about 5 months of no problems with the case. It seems last night there wasa power outage, this morning I found the RPI off. Turned it on with the button and noticed the fan was spinned up but never stopped even if temperature was around 30ºC and the config is the default.

Tried reinstalling the tools, apt-upgrade and a few more things, nothing worked until, after reading this, I pulled the plug.

I’m trying to figure out what the hell might be causing this nonsense behavior… but there’s so little information about how to troubleshoot I’m leaning to move to the one proposed in this thread rather than figuring out the pyhon script

I’ve had similar behaviour, seems to be related to I2C: