I2C issues on Argon ONE V2 case

I have 2x Argon ONE V2 cases and 2x RPi4 8GB models. I also have the IR remote. I first noticed that the IR remote was behaving intermittently, sometimes it’d power down the unit, sometimes it wouldn’t. I also noticed that sometimes the unit would fully power off with LEDs off and sometimes it wouldn’t. When I was more in tune with what’s going on I looked closer and noticed that behaviour also coincided with the fan staying on even though I’d just turned the unit on and it was stone cold. This behaviour persists across 32 and 64 bit Raspberry Pi OS across both units, across multiple fresh reinstalls. I recall also having issues on Ubuntu 22.04 but I have only used that for a short period and most testing is on RPiOS. It is intermittent, in a test just then the power on and off on the remote worked 3 times and on the 4th time didn’t work.

The common factor is that when everything was working nicely, you see device 1a when running i2cdetect -y 1, and when nothing is working, you see no i2c devices.

I have tried resetting the i2c bus by doing things like rmmod to disable i2c and re-enabling with modprobe, to no avail. I haven’t yet been able to put together a sequence of events that is guaranteed to fix the issue (or cause the issue). Sometimes disconnecting power works, sometimes not. The issue persists even without having installed the shell script, it can be observed simply by looking at the output of i2cdetect or trying to run commands like i2cset -y 1 0x01a 0x64 (fan full speed) or i2cset -y 1 0x01a 0x00 (fan zero speed).

I used to think you could tell early on if it was going to work on startup (if the fan turns on on power on but turns off after around 5 seconds, then it’s all going to work). However it seems that the fan may remember last state so this isn’t a sure fire way to detect it.

If I had to guess what was going on, I would guess that something isn’t initialising correctly on the i2c bus on the Argon One V2 case side, and my logic for that is that the i2c detection and other items aren’t reporting a fault in the Raspberry Pi OS. I also think it’s not just a one-off glitch seeing as I get identical behaviour from two completely independent sets of hardware.

Any thoughts on further avenues for diagnostics would be most appreciated.

1 Like

Have you ever gotten a solution to your issues here?

I am running an RPI 4 on RPiOS 64-bit inside an Argon One M.2 case with and Argon Power Supply and WD 500GB SSD. I know when I was running 32-bit that the argon1.sh worked fine and loaded without errors. The fan worked fine. Then after upgrading from scratch to 64-bit it also loaded fine and the fan still worked.

Then after some recent update the fan stopped working per the argonone-config settings. I tried uninstalling the Argonone script and reinstalling it. When I do, I get an error “modprobe: FATAL: Module i2c-dev not found in directory /lib/modules/5.15.76-v8+". I have searched the web for incompatibilities and tools for i2c. I know nothing baout this. But I have found some sites for testing whether i2c is installed correctly? Som of the tools don’t reflect that i2C is working. I tried reloading i2c. no errors on this install. However I still get the modprobe error and the fan doesn’t work.

Also:

Any suggestions are welcome,

LJ

I’m having the same issue. If someone finds a solution, please post it here! I’m considering changing the ONE case to something else.