Have I bitten off more than I can chew with the EON (or is my hardware faulty)

Hi all, I was wondering if I am the only person struggling so much with the EON? I have not had a single stretch of reliability with it since getting it and I am losing my patience.

Is OMV really this difficult to work with? I have another raspberry pi setup with octopi for my 3D Printer and that one is bulletproof. I don’t consider myself a techy but I have worked with Arduinos and Raspberry Pis and tend to fumble my way through the learning cycle and land on a working system eventually.

My latest challenge is that I cannot even plug an HDD in, I installed a brand new HDD this week (Thinking that my secondhand HDDs were the issue) and within 5 minutes it gets stuck in, what sounds like, a power up/shut down loop and OMV cannot see it. If I move the HDD to an external enclosure, plug it into my laptop, it’s perfect. If I run OMV with no HDD it’s perfect. So that’s my HDD fine and OMV fine, right?

My only conclusion is that the Argon EON just does not work. I am at a complete loss and strongly considering tossing it once and for all. It just kills me the amount of money I have spent on it and never had it work reliably.

Are there any last ditch solutions that I should try?

My last attempt at this stage is going to be setting up OMV with just the pi and an external HDD (none of the EON bits) to see if that pinpoints the issue as a hardware malfunction.

UPDATE: Looks like it is my EON hardware that is faulty, everything works fine when I run just the pi and HDD. Next step is trying to resolve this direct with the folks at Argon I guess :roll_eyes:

I have experienced lack of power delivery from the provided EON power adapter, i bought a 100watt power adapter to stabilize my EON with 16TB of NGFF SSDs.

Might want to give that a try? Find an bigger universal power adapter with same voltage rating and more amps.

Thanks, I’ll give that a try

This issue has been solved by Argon very kindly replacing the SATA Board on my EON under warranty. For some reason the board was not delivering enough power to the drives and the system has now been running perfectly for months.
I know of only one other person having the same issue but nothing beyond that so it is not a common issue but there is always a chance it pops up in the future.


i have the complete same issue, looks like i must reach the support.
with one drive and OMV i have no problem, but did i connect a second drive the Pi goes in a start stop loop.

After 3 Months later i got my replacement board’s from the Argon40 Support its took a while but now is everything working fine, i got some new revisions of the boards.

Power Board old: V2.4
Power Board New: V2.5
SATA Board Old: v3.4
SATA Board New: v3.7

there are some new compontens on the boards so i hope this fix the issue in the future.

1 Like