Failed to open device: 'sdcard' (cmd 371a0010 status 1fff0001)

Hello everyone
I got my argonEon today, finally!!! I mounted it following carefully the guide, in order to avoid damage, but the problems began: any type of sdcard inserted (I tried 3) give the same problem “Failed to open device: ‘sdcard’ (cmd 371a0010 status 1fff0001)”. I have disassembled and reassembled all components several times but nothing to do. I reinserted the card on the raspberry and it works perfectly. According to my ignorance it could be the defective Argon card reader. Do you have any ideas or advice?

It may well be the flat ribbon cable. I had to insert/remove mine several times until I realized it was not fully seated…

Yes, the connection is perfect, on first boot i read: card detected

the internal usb reader works, the system starts. Again, in my opinion, the problem is in the sd card slot.

Hi,what operating system are you using ??

I’ve tried with raspbian 32bit and 64bit desktop and lite, no dice, only works with the internal usb reader

@teuteuguy, you’re not the only one.

1 Like

we hope that the engineers can give us an answer

If after checking the SD card cable extended is firmly install in the socket and it still not does work, can contact our support at for replacement of the SD card extender.

I have sent the e-mail to your service department

I was getting the same thing on another pi. i had to use a previous version of Raspberry Pi OS.