SD-card extender/slot on the EON not working

Has anyone had any problems with the SD-card slot on the EON? The Raspberry Pi seems to recognize that a card is inserted, but cannot initialize boot from it. I’ve tried to remove the “SD-extender” flex cable and insert it again, but that doesn’t help. I get the following error: “cmd 371a0010 status 1fff0001”

Edit: To be clear, I can boot just fine if I insert the SD-card directly into the Raspberry Pi.

Edit 2: I’m utterly baffled right now. I can boot if I insert the SD-card or plug in the NVMe-adapter directly into the Pi, but not via the EON. Starting to wonder if I received a broken copy of the EON. :cry:

Edit 3: Well… after quite a lot of tinkering I realized that the SD-card extender seems to be the issue. Not sure how or why, but when I connect the “extension” flex cable to the Pi SD-card reader all hell breaks loose (I get the error stated above) and that’s with or without an SD-card inserted into the EON card reader/extension port. As far as I know (I used a multi-meter) the flex cable is not damaged and also properly inserted. :confused: Without the flex cable everything works just fine, for now.

I have a similar issue, my refuses to boot from USB when I have the card reader extension port connected without a card inserted. I have to leave a card inserted to be able to boot at all.

Interesting, haven’t tried that combination. I eventually decided on removing the extender flat cable and boot from a NVMe drive through the internal USB. Waiting for Argons technician to come up with a solution.

1 Like

for issue for the SD card extender, can email our support at, we can send a replacement SD card extender when we resume operation on 3rd week of february.


Are you sure it’s the flat cable extender? A SD-card seems to be detected, but the Pi can’t read/connect to it.

Edit: Never mind, I seem to be getting the same “card detected” message even without the SD-card inserted. But as I mentioned above, I’ve tested the flat cable extender with a multimeter and it seems to be fine.

I have a very similar issue; however, I wanted to add my unique findings in case it helps.

Same SD-Card error as above with or without a card in. However, if I try and boot from the SD-Card, it starts up, but the Argon boards “shut-off” after a few seconds. The power stays on the rpi though, as the red/green lights on it are active. But no power goes through the adapter boards. It seems cold booting with the sd card “shorts” something?

However, I can boot, then quickly insert the SD-Card in and nothing gets “shorted” and it boots normally, showing the SD-Card error, then booting into my OS on the NVME. All components work (minus the sd-card of course).

The things I put in quotes are what the system seems like it is doing, not sure if that is accurate though.

I had a similar issue booting when I first setup the system. I removed the small ribbon cable and reinserted it a few times, it finally seated securely and everything now works.

Might want to make sure the cable is seated firmly on both ends

That’s quite interesting. My flat cable has connector marks on its pins, so it should have been inserted properly. :man_shrugging: I might give it another go next week.

I got the same issue on my eon. I try to reinstall the cable a few time but always with the same result.

Same issue for me, the sd card boots correctly if inserted directly to the pi, but using the flat cable fails with the same error pictured above.