Blstr DAC and PiCorePlayer

I’m trying to configure my new Argon ONE V3 M.2 NVME with the Blast DAC for use with PiCorePlayer (PCP). I have successfully installed PCP on the SSD and it boots and works except for the Blastr DAC. I cannot install the BLSTR DAC configuration - I get the error "-sh: bash not found.

I tried selecting the Audio Source as HiFiBerry Dac+ in the PcP options but it does not work either.

This message implies that only sh is used as shell, and Bash is not available. Maybe busybox is in use with a reduced command set. You doesn‘t wrote which command you tried before to trigger this error message.
You should provide more details. Otherwise it‘s like looking into a crystal ball.

I‘m not familiar with piCorePlayer. But the important settings for BLSTR DAC (HiFiBerry) are usually set in config.txt. So start with providing the content of the config.txt.

Error received after entering this:

If I try to configure it as a HiFiberry Dac+ as indicated further down I get this:

The script is intended to support main stream operating systems only (like PiOS, Ubuntu…). Customized and minimized distributions like piCorePlayer, LibreELEC, batocera and so on are counterparts of that and isolates most things behind the (G)UI to make it easier for novices.
But for troubleshooting or extension (fan control + power button events of the Argon ONE) it makes it more complicated.
The result: the will not work for you and you will need a customized variant or replacement of it. Maybe there already exist a solution for the Argon ONE V1/V2 which could be ported to Argon ONE V3.

The common part of all distributions is the bootloader config/EEPROM and config.txt on Raspberry Pi. That part can be set manually too, without the
In the config.txt there are the dtoverlays addressed for soundcards/HATs. But you wrote, that you boot from SSD. If you mean the NVMe, then the following tutorial may vary and the correct device is /dev/nvme0n1p0.

Be aware: there also some reports of other buyers in this forum, where the BLSTR DAC or the daughterboard had an hardware issue. So there is a risk remaining and perhaps a good idea to test the hardware first with PiOS and the script, to check if your hardware is working right. When this works with PiOS, then the chance/attempt to get it work with piCorePlayer is less time consuming.

Please first check which devices/partitions are available with lsblk.

Loaded Pi OS Lite and was able to complete the Argon script. Next, I loaded Volumio and was able to run the script process there and confirmed audio was working.

After loading PiCorePlayer I was able to SSH in and identify this as the NVME volume:
Screenshot 2024-06-22 004114

What I Don’t know is what needs to be added to the Config and/or Command file there.


I asked for the content of config.txt because other entries can make some troubles too.

Depending to the current kernel version (and the provided dtb files) used by piCorePlayer the following lines must be there at the top of the config.txt:


Detailed informations about that and recommendations for kernels older than 6.1.77, you can find here:

I really appreciate your time and help - if I can’t get this to work with PiCorePlayer then my only other alternative is to try RoPiee; otherwise the Argon case and DAC are useless for me.

Here’s is what my Config.txt looks like. The highlighted sections are what I added - the red lines are what PcP added when I tried to select the the HiFiBerry Dac+ from the configuration options.

AS a side note I was able to plugin a USB iBasso dongle and PcP detected and configured it instantly. I actually have a HiFiBerry Dac Pro and it similarly setup and was recognized easily.

piCorePlayer 9.0.1 uses kernel 6.1.77, but doesn’t provide the new overlays for HiFiBerry, so you must use the old style.
The HiFiBerry DAC Pro is a different hardware design which works as master, so there is not needed to add the slave parameter and works out of the box. That makes the different in combination with a RPi5.
Please see:

Remove/comment out all of your lines below “# Argon Modifications”.

# dtoverlay=vc4-kms-v3d,noaudio
# force_eeprom_read=0
# dtoverlay=hifiberry-dacplus

append only these lines:


If that doesn’t work, move the last dtoverlay line to the top and add the empty dtoverlay line before it. They must be the first 2 lines of the [all] scope of config.txt or even at the very beginning of config.txt:


Be aware: The empty dtoverlay line is no copy & paste error and important. This is the replacement for the deprecated “force_eeprom_read=0” line !