Argon POD Kit - HDMI-USB Module - No Video

I have a Raspberry Pi Zero 2W and purchased the Argon POD Kit - (Case+HDMI-USB Module). I am using the standard Raspberry OS for x86 systems.

When I use the HDMI-USB module, the video comes on for a split second then goes blank. When remove the HDMI-USB module and connect the micro HDMI directly to the Pi Zero, the video is fine. Is there a driver I need for the HDMI-USB module? Do I need to alter the OS config file to address the HDMI issue? Any guidance is appreciated.
Thanks,
LDL

I have the same issue. It’s not the monitor’ I’ve used the Pi Zero 2 on several monitors, with and without the HDMI-USB pod and without.

Symptoms are exactly what @ldl describes - It’ll flash the Pi initial screen and then go off and quietly sulk if the POD is on, or boot normally and give me a desktop on the monitor without the POD connected. It fully boots even with the POD; I’m able to use VNC to connect to it. I’ve used several HDMI cables on the POD as well. Bog-standard Raspberry OS Bullseye.

I wouldn’t expect it to be a driver issue since the screen, however briefly, does manage to display. Could it be a power issue? The supplies I’m using are rated at 5V 2200 mA output.

Did some further testing, using an Outdooor Tech 47Wh capacity power brick, which will let a Pi 3B+ run a web server with no problems. Same result.

So, I popped a Zero W running Buster and it fired up and worked fine. One thing I noticed while fitting the Zero W in - the HDMI port for that fit the HDMI cutout in the ZeroPOD better than the HDMI port on the 2W did - it went flush to the housing while the 2W port was slightly recessed. I tried connecting the 2W, not in the housing, to the HDMI-USB POD and fired it up. Result - the 2W fired up and gave me video like you’d expect. I found the same thing with a second 2W -in the housing- video died; without the housing - full video.

Both the Zero 2Ws I had came with pre-installed headers; I don’t have one without the header pins to try. But the header pins weren’t causing a fit problem.

As an incidental (unrelated) note, the manual (p. 5) implies (Assembly Instructions Step 5. “Place the desired Top Cover for your given use case”), and the packaging (box for “POD”) states there should have been two top covers - mine only came with one, the solid flat one.

No explanation for why connecting a Zero2W without the POD case will work using my Pi [0-3] power supplies, and ZeroW in a case works fine with that supply, but the 2W in the POD won’t.

I discovered that Argon40’s POD page says that they expect you to use a 3A 5V power supply. It’s not mentioned on the paperwork that came with the POD, or on the Amazon page I ordered it from. But I dug out a USB power adapter for one of my phones that is rated at 5V 3A and it does work given that power supply.

Conclusion: Poorly-documented product, but it really does need 5V 3A power supply (which, conveniently, they sell) even for a Pi Zero2W. Given that, it will work.

Just a +1 from me. Very excited to receive this case and disappointed that the HDMI cuts out half way through boot. Was sure I had a dud then found this forum thread. I have even tried my “official” Rasperry Pi4 Power adapter (5.1V, 3A) with a micro-usb adapter and same thing happens. Argon’s own 3A microusb adapter doesnt seem to be available in the UK so I’m reluctant to spend more money on Amazon trying random power supplies.

Just my 2c but if the USB/HDMI module had a USBC power socket instead I could have used the Pi4 PSU in my 4/M.2 or Zero/Pod cases interchangeably. Doesnt seem any advantage in keeping the micro-usb power if normal PiZero adapters don’t have enough power for the case.

Just tried what @Jon suggested and indeed, power was a red herring. A Zero2W connected directly to the POD USB module works absolutely fine, Zero2W in POD case does not so does seem to be some kind of misalignement or connection issue ?

Still disappointed :-/

OK, update. Leaving this here just in case anyone else finds the thread.

I dismantled the POD case, removing the screws from the bottom. I attached the HDMI/USB module while the bottom was off and gently levered the pi against the USB/HDML module so it was firm and secure. then I screwed the bottom back on.

Result: Success. Starts up fine even on a 2.1A usb connection.

So, my conclusion is its definitely a connection problem and making sure the HDMI connector is securely attached before screwing the pi into the case does the trick.

PHEW