Argon One V3 nvme not recognized

You seems to have the 2TiB model. This could be to large, because 2TiB was a critical limit in the past. Did you have tried to resize/shrink the root partition at NVMe to the same size like as on the SD card?

I haven’t yet tried to resize.

I’ve seen your suggestion but what i used imager to install pi os on the nvme which creates a 5gb partition. I could not make it boot from nvme at all

It boots perfectly from nvme and using nvme if the sd card with pi os is inserted and the nvme was created with sd card copier ( keeping the same partition uuid) and the size will be 1.8 TB. Also, to be noted… Once installed, the nvme is not recognised anymore so having to default to the first option in the boot order of raspi-config

Why i hesitated to resize the 1.8TB partition is the fact that it doesn’t even get to the partition. The pcie link is not even enabled.

Is my logic wrong?

Ps: @AbeO the firmware upgrade has not made a difference in my scenario. Would you like to give a step by step of how you actioned your installation and transition from sd card to nvme? Did you use the imager or sd copier for the nvme? Did you use the argon scripts or manually amended eeprom and config.txt?

During the boot phase the bootloader is the steering component. Keep in mind, that the RPi doesn’t use a grown BIOS/UEFI firmware which was developed/bug fixed over decades. It’s more like the counter part - keep it simple. So I would suspect, that it doesn’t supports GPT and hit some limitations which are 32bit related (cluster counts and so on…) and fixed in current BIOS/UEFI versions, but not in the bootloader.

This information could additional be important, because it changes the EEPROM configuration:

Also, to be noted… Once installed, the nvme is not recognised anymore so having to default to the first option in the boot order of raspi-config

The script tries in combination with to update the bootloader version, force 5000mA power supply and forces the PCIe detection, not only the boot order ! Perhaps you should compare before and after and remove some lines temporary like this:


EDIT: After checking the script. This script sets the EEPROM to default values. The following line will be missing after that, until you execute again.


This line seems important to get the PCIe to work, because the NVMe needs additional power. The line PCIE_PROBE could be optional with current releases of the bootloader. It’s only needed if the bootloader doesn’t recognise the NVMe by self (no HAT+ device).


Delete the Team/Teamgroup MP33 drive from the compatibility list above for the Argon ONE case.

I purchased an Argon ONE V3 M.2 NVMe PCIE case about a month ago to use with my Raspberry Pi 5 (8GB model). I then bought a Teamgroup MP33 256GB NVME to use with it, and could NOT get it working properly using the most current DietPi distribution (based on Debian 12). I also tried the current 64-bit version of the Raspberry Pi OS, and that didn’t work properly either. In both OSes, the NVME drive would be recognized properly, but would have VERY periodic instances of delayed reads…most in the range of 10-30 seconds — very annoying!

Finally, I returned that drive and purchased a Crucial P3 500GB NVME, and it worked perfectly. I also enabled the PCIe 3 mode, and am getting Read speeds in excess of 870 MiB/s and write speeds of 400+ MiB/s (using the DietPi distribution).

I really wish Argon40 would work on an OFFICIAL NVME compatibility list for their cases, as that would save a lot of time and heartache. Hopefully soon…


1 Like

i AM USING A 2TB Western Digital Blue SN580 NVME PCIE card. Works great. Took a little work, but I installed KALI LINUX on it. Boots up just fine.

Will do. Meanwhile I bought a NVMe Base from Pimoroni and it worked right away - with the same NVMe SSD I tried with the Argon case.

Looks in your case really like a faulty part of the Argon ONE V3.

I learn every day new information about RPi environment to complete the jigsaw. For example that the cable for the PCIe extension pcb shouldn’t be longer than 5cm from end to end (including the leads).
The idea to use this sensitive PCIe port for the masses, resembles me a ride with the razor blade.

I captured the monitor at boot time as you wished.

Thank you for this photo. I wasn’t aware, that a new bootloader was released.

I did everything I could, including updates. I wonder if replacement ribbon can be bought. That’s the last resort.

1 Like

I have found this interessting discussion regarding the SUSCLK signal.

I wonder if this was adapted to your Pimoroni NVMe base and possibly missing at Argon ONE V3.

Do you have already tried what happens if you add these to your cmdline.txt?


I think this would not helps regarding the boot issue, but perhaps the device will be detected by the kernel.

Good point. I’ll check it out.

I gave a shot but it didn’t help.


Where I was a little bit afraid, as I found this statement that the SUSCLK was removed on new hardware revisions.

If this clock signal is important, than it’s like a lottery to get it work if you doesn’t know before what you get.

Thank you for all the involvement in this thread.

I did read this at some point too.

I am returning the sn850x and i got Crucial P3 Plus 2TB coming my way.

I’ll write a quick update asap

1 Like

In my opinion they should come with a spare ribbon.

1 Like

The Online statement is a Lawsuit waing to happen.

  • Boot your Raspberry Pi 5 from an NVME M.2 Drive.

I have now tried 3 differnt NVME Drives, NONE are recognised.

I can confirm that all works as expected using a crucial p3 plus 2tb

thank you all for all the help here, especially @HarryH


This isn’t necessarily an Argon ONE problem, as the Raspberry Pi itself is known to be very picky in regards to NVME drives (and maybe future eprom updates will help with this?). That being said, Argon ONE could provide an “official” NVME compatibility list to solve frustration for their customers. A good starting point is Pimoroni’s supported list here: NVMe Base for Raspberry Pi 5 - NVMe Base.

However, I tried one of the drives on this list (the Team MP33) and it did NOT work properly with the Argon ONE case. I then tried a Crucial P3 M.2 and it worked perfectly. YMMV