Argon One V3 nvme not recognized

Hi all,

I just received my argon one today and after setting up the enclosure and slotting in a Samsung 970 evo, I ran into an issue: the drive isn’t showing up on either Ubuntu 23.10 or Raspberry Pi OS. I’ve tried both operating systems, but the SSD just won’t appear. Help please

1 Like

I had a similar issue until I updated the firmware. And the entry in the /boot/firmware config file.

2 Likes

Have to make sure to follow instruction in the manual. also make sure that the cable are installed properly.

I tried that but it just send my pi in a boot loop I get 7 green blinks and then reboots and it just repeats

7 green blink indicates that Raspberry Pi cannot find kernel.img or valid boot drive.

1 Like

See if can post photo of how the ribbon cable is connected?

I try with a brand new Western Digital Blue SN570 … no luck ! not booting at all…

But, It’s booting from an SD Card on the case… and i follow the PCI cable instruction on the manual, and edit the config.txt to add (on the All section) the 2 value describe on the guide… but boot from NVME seems not working… for now.

So what i did, initally boot with microsd card… and set the BOOT_ORDER=0xf416 and PCIE_PROBE=1
it ask to reboot… then i reboot
try to update firmware… but it’s the latest one…

The, add in config.txt
dtparam=nvme
dtparam=pciex1_1=gen3

no luck… .then… i re-flash another old NVME drive i got (500 GB, Toshiba)… apply the setting on config.txt… and this one is booting !

So it seem the WD Blue SN570 is incompatible

1 Like

Both the ribbon cables are in tightly and won’t go any furthers. Here’s how they look. The cable on pi look exactly the same it won’t go any further

Same here. Followed instructions to the letter.
I can boot using the NVME in an Argon One v1 NVME base and USB cable.
I actually wrote the OS to the NVME memory using the Argon One v1 NVME base, modified the /boot/firmware/config.txt with the nvme stuff then installed and ran the Argon-eeprom.sh - it boots quite happily in the Argon One v1 NVME base
The PI5 is not seeing the NVME in the Argon One v3
I’m getting the usual Bootloader failed messages… but possibly significant, I get a PCIe warning.

PCIe timeout:0x0001e08f

I know the ribbon is the right way round and seated correctly, checked twice and then again !

It looks like my issue is that the NVME board is not being discovered.

Cable seems to be installed in the right orientation. Would just suggest that cable be checked if they are plugged in properly.

Interestingly, fitting the Argon One USB NVME base with the NVME card that doesn’t boot in the v3 base onto the Argon One RPi5 case top, everything fits and it boots happily. £49 quid wasted ?

Board and ribbon are 100% tested before they are shipped. So in most case, if they are installed properly, it should work, except for some SSD drive not supported by Raspberry Pi PCIe protocol. May i ask what kind of SSD drive is currently being tested?

I’m using a Samsung 970 Evo 1TB

If possible to test with another drive. There are reports of Samsung 970 EVO not showing up at boot when use with Raspberry Pi 5.

I’m having the same issue using a Samsung 980 Pro 1 TB drive. This particular drive works fine with Pimoroni’s NVME base, so I know that it’s at least compatible with the Pi 5.

Yes, the samsung EVO 980 works in our test. So if this is the case and the ribbon are installed properly, i would suggest contacting our customer service team, they will help resolve the issue.

Want also to note for Argon One, the nvme base need to be screwed on back to the case for the nvme to work. We use the pogo pins to draw power for the nvme drive instead of relying on the cable. The pogo pins can provide 3A of current instead of the 1A provided by the ribbon cable.

Wow… i search everywhere to see that Quality of picture ! to be sure i was configuring everything correctly !

But yes… i did it like this picture : @argon : adding this picture on your guide will have better impact, then the text (for those who are more "visual)…

I’m wondering… as the WesternDigital SSD not working… but Toshiba is… so i’m wondering…

  • is it incompatibility with the RPI5 only
    or
  • incompatibility with the controler on the Argon

I will see soon… as i also order (and received) a nVME bottom for my Argon One2 (so communication is USB between RPI4 and this device), and intend to test it this week.

Q? : if it’s an incompatibility with the Argon board… Firmware updatable ? (not an issue for me, as i got different nvme drive with me… the WesternDigital were new… and the Toshiba were 3 yr old)

ive just had the same problem with a samsung PM981 drive, could not get it to recognise it at all, however i then updated the EEPROM firmware using this command and it worked right after a reboot, check this for an updated version and see how you go

sudo rpi-eeprom-update -a