Argon One V3 for Raspberry Pi 5 - not powering up

When I attempt to power up the Argon One V3 with a Raspberry Pi 5, there is no power. I have ensured that the HDMI Power Board is firmly connected into the Raspberry Pi Board. The screws are aligning properly and I’m able to close the case. I have tried both CanaKit 45W USB-C and a Canakit 27W USB-C power supply without success. The Pi works normally if I plug it into a power supply, so I know that I have a functioning Raspberry Pi 5 unit. The power jumper is currently in the default 1-2 position.

Have I missed something? Any help would be appreciated.



1 Like

Once I placed the power jumper to always on (Pin 2-3) the unit does power up. It took a few attempts to seat the Pi into the case before power worked. I’ve not been able to get it to work in Pin 1-2 position so I will just leave it for now.


1 Like

i have the jumper on the 2-3 position, and it still does not power on using the official 27W raspberry psu, without pressing the power button, which is bad in case i have power loss (ups, proper shutdown), and resuming power won’t turn the device back on.

is there anything else i can try?

Your both cases sounds a little bit different and like a defective pcb. Nonetheless maybe should this give it a try:

afaik the recommendation here is to have everything lined up and connected properly, i think i’ve done that, as the pi5 is running fine after the power button is pressed.

my problem is the need to press the button, i want to have my pi starting up after a power outage, so its ready 24/7 without human interaction. i have the jumpers in the proper place, but once i issue the shutdown command, the board shuts off power to the pi, and it won’t restart on a power cycle.

can i fix this somehow? RMA sounds like a bad idea, as i’m already dependent on the nvme feature.

The RPi5 expects a working Power Delivery negotiation to start. Thats one of the reason to use original 27W PSU. The Argon ONE V3 just does that in behave of the RPi5 and delivers the power without this protocol information. My intention was to ensure that the internal connection makes no additional issues. You can try or not to rule out that, it’s up to you.

All other indications (jumper is already set to position 2-3) directing to a contact- or soldering issue. If you doesn’t want RMA, the only chance I see is to ensure the last firmware version is flashed to the case (described in the PDF manual of the case). And if that not helps, take your multimeter and follow the pcb if you can find and repair a bad soldering point.

Do you have checked if the issue also occurs if you disconnect the NVMe?

thank you for your tip, pin 2 was not soldered to the pcb at all. after fixing that, the PI started up immediately after i plugged in the power.

1 Like