Argon ONE M.2 & IR Remote power

I just purchased the Argon ONE M.2 case and the IR remote. I’ve installed libreelec and it all runs as expected, except for the power button on the remote. Rather than powering off the device, it just seems to trigger the Kodi power options. If I manually select to shutdown, it puts the case into a standby mode that can’t be powered back on by the remote. Additionally, sometimes the remote WILL power off the device but it seems to be totally random if it chooses to do it.

Any advice would be appreciated. Thanks

To get the shutdown procedure working right you need an additional service running which observes the power button signal (indirectly through the MCU) at the case and also communicates with MCU inside the Argon One case.
The simplest solution for that is to install the ArgonForty Device Configuration Add-on version 0.0.9a if you use LibreELEC. For all other distributions you need to install a service like from the installation process.

1 Like

Thanks for the reply, Harry. I am using LibreELEC and do have the ArgonForty Device Configuration add-on installed, along with the Raspberry Pi Tool and System Tools add-ons. I followed the instructions included with the remote to the letter.

Sadly, the shutdown still seems to be inconsistent if it works at all.

Are you sure that you use one of the versions I have published in the linked LibreELEC thread?

I’m asking because I am have never seen a version newer than 0.0.1 of this Add-on (different archive name but content the same coming from Argon itself which includes the needed shutdown script: /storage/.config/

Powering on using the remote control or the power button (should make no difference) on the chassis will not work if the previous power down process did not tell the MCU to cut off power after the PI’s serial port status changed. This communication is part of the shutdown script. If it is missing or malfunctioning, the operating system will halt, but the Pi will remain idle in a loop because it lacks the power interruption required for a graceful shutdown. In these cases, the red LED lights up statically and the device will not respond to the power button or remote control until you hold the power button > 5 seconds (forced internal power cut) or you making the entire case powerless.

Hint: After a graceful shutdown the red LED should be off ~10 seconds after shutdown of the Pi.

I recommend the update to the current version 0.0.9a and give it a try.

You were right, it was using 0.0.1 so I deleted the add-on and installed 0.0.9a. The first time, it shutdown perfectly so I powered it back up via the remote and when I went to shutdown again it was back to the same issue. It just opens the Kodi power options.

So I pulled the M.2, did a clean install of LibreELEC and followed your instructions in that post again for all installing the add-ons in the right order. Again, first time it powered down perfectly but as soon as I powered it back up and went to power it off for a second time, it just opens up the Kodi menu. And no matter how many times I push the power button, it still continues to open the menu.

And if I power down the device using the Kodi shutdown, then I can’t power it back on using the remote.

I will try to help you, but I need some information more detailed:

  • only to be sure: we talk about a Argon One M.2 + RPi4 not Argon One V3 + RPi5, right?
  • Which LibreELEC version do you use ? 10 / 11 / 12
  • CEC enabled ?
  • after the second shutdown: the red LED is going off after 10 seconds or lights infinity?

Please can you try the following (important: don’t use the power button on your remote control for this test):
0.) unplug the power from the whole case for some seconds
1.) start with power button at the back side of the case
2.) wait until KODI menu is available
3.) navigate to Power menu, select shutdown and apply
4.) wait and look if the red LED short flashes and 10 seconds later is going off
If the LED is going off the shutdown process was OK
5.) try to repeat step 1 - 4

Thanks, I really appreciate your help. In answer to your questions:

• Yes, that’s correct. I’m using the Argon One M.2 + RPi4 8GB
• I’m using LibreELEC 11.0.6
• CEC is currently enabled
• Red light goes off after both shutdowns, red light only stays on if I use the kodi power down option after it stops working

I followed your instructions and it worked exactly as you said. Power light flashes once and then goes off after about 10 seconds. It worked correctly on both attempts.

The fact that the test scenario works indicates that the shutdown script is working.
Can you please extend the test as follows:

important: don’t use the remote control power button to power off for this test
0.) unplug the power from the whole case for some seconds
1.) start with power button of the remote control
2.) wait until KODI menu is available
3.) navigate to Power menu, select shutdown and apply
4.) wait and look if the red LED short flashes and 10 seconds later is going off
If the LED is going off the shutdown process was OK
5.) try to repeat step 1 - 4

30 minutes ago I updated my universal remote to simulate the Argon remote. In my initial tests it works, but I noticed that the reboot (triggered via the remote’s power button) seems to be faster than the first one with navigation to the power off menu. Maybe this is the same thing you observed. I’m afraid that some processes will be skipped if the shutdown is faster. I’ll try to research this.

I’ve figured out a few things now. There are a few things I should tweak to speed up the shutdown process. However, a real problem is that if you press the power button on the remote even once, the MCU inside the Argon One case will trigger a power outage after 10 seconds. This applies whether you’re navigating the current menu or watching a movie, it’s as if you simply unplugged it.

This is why the shutdown process is different when you navigate to the power menu. If you use the power button on the remote control, the proper shutdown process will never complete cleanly.

I completed the second test and it worked. Takes a bit longer to shutdown but the LED short flashes and then goes off. I tried it two times and it worked both times.

So does that mean it will never work correctly? And does a universal remote work differently and avoid the power outage?

After some bug fixing and optimization of the shutdown procedure, I could reproduce your issue (by the way: the kind of remote control makes no difference). The opposite was the intention for the optimization. :crazy_face: But on this way I have found a workaround for the remote control shutdown.

Shutdown with the remote control power button is not risk free because of the 10 seconds limit for the shutdown process and a potential risk of data corruption. But who cares? :wink:

Please try version 0.0.10.

Installed it and it definitely seems to be better. The second time I shut down it had the same issue but I think maybe I tried to shut it down too quickly. If I leave it for a bit after booting up then it seems to be shutting down from the remote every time. I’ll monitor for a bit and see how it goes.

Thanks for all the help and work you’ve done, I really appreciate it.

If this is the same situation that I was able to reproduce here, then the problem is that the MCU doesn’t seem to recognize how the UART level drops.

Remote control power button pressed → 10 seconds timer starts → shutdown is initiated → red LED turns off, but it seems that it doesn’t respond to the power button on the remote to get it on again.

Please try in this situation (unsuccessful shutdown):

  • The red LED must be off
  • Press the power button on the remote control
  • Wait 10 seconds (MCU cuts off power internally)
  • Press the power button on the remote control again to boot

If it happens frequently, you should try disabling CEC. Even if you have Bluetooth enabled, it could interfere with the UART.
It’s just grasping at straws: If you have a different power supply, you can check whether the voltage levels generally fluctuate.

It seems to be working if I do what you said and wait 10 seconds+ after an unsuccessful shutdown. It’s not in general use yet though so we’ll see how it holds up. If it continues, I’ll take your advice and try disabling CEC or a different power supply.

Thanks again for all the help.

You’re welcome. I was also interested in fixing the add-on.

If you have time for, please can you check which bootloader/EEPROM version you currently use?
vcgencmd bootloader_version

and the current settings:
vcgencmd bootloader_config

Of course, here you go:

version 8ba17717fbcedd4c3b6d4bce7e50c7af4155cba9 (release)


It appears that it is “just” a timing issue due to the hard shutdown limit. The difference could be that you are using a different M2.SATA device than me, 4GiB vs. 8GiB memory, network mounts, addons…

I’ve made some progress now, so it’s worth trying out version 0.0.11d.

Oh nice, thank you. It’s been working pretty well at the moment (aside from an initial blip) but I’ll install this later and see how it goes.

(and sorry for such a slow response)

I updated to version 0.0.12 last night and so far, it hasn’t shut down correctly once. I’m also seeing the plugin config error pop up every time I start it up. Will monitor and get back to you though