Argon EON HHD/SSD problem looking for help

I have a strange problem I need help with.

After I received the EON I installed 2 Seagate Ironwolf 8TB drives, 1 Seagate 2.5" 5TB drive, and 1TB SSD. I also installed a 1TB M.2 in USBA.

Once I installed OMV 6 the drives were seen, but once I tried to mount them I got:

I/O errors during read of /dev/sdc
I/O error during read on /dev/ssd.

I then tried using TwisterOS from a MicroSD card to see if I received the same error on those drives.

I got the same errors! Therefore it’s not related to the OS being used but hardware related.

I then wiped and reformated all the drives with the same result.

My next option was to return the 2 Seagate Ironwolf drives and I purchased 2 Toshiba N300 12TB 3.5" NAS HD

I now have the same Issue.

Has anyone had the same issue? At this point, I think the SATA board is defective,

I would be grateful for any help.

@GM46 - take a look at the following related thread :

I would recommend removing all of the SATA drives and then (using a single hard drive) test each SATA connector individually. In my case, only one of the SATA connectors was problematic (likely power related).

Also - note that the Argon support team is currently out on holiday, returning to the office on 20 February.

I will try your suggestion. What I did try is connecting the whole SATA board to a Linux Mint computer and also one running Twister OS using the USB3 jumper removed and keeping the power on the EON so that the drives had power, still the same issue. But as you said I will try each connector individually.

I want to ask if there is any Diagnostic app that runs in Bullseye or Linux that can stress test the connector using a GUI or in the Terminal.

A Linux distribution agnostic method to stress test the SATA board would be to connect two individual hard drives, ensure that Smartmontools monitoring has been enabled, and then perform an rsync job (between the two drives) for a number of hours.

Also note that your Seagate 2.5 inch hard drive (and possibly your Seagte 3.5 inch drives) will likely need USB quirks applied (to disable UAS) : SAT-with-UAS-Linux – smartmontools

1 Like

Regarding “disable UAS” is that during using smartmontools or also when using OMV

For Seagate 2.5 inch (and possibly 3.5 inch) hard drives, disabling UAS will likely be a compatibility requirement (because of the Argon EON’s USB to SATA interface).

Disabling UAS for Seagate 2.5 inch 5TB hard drives is definitely a stability requirement for Ubuntu version 21.10 (64bit).

Thank you for the update.
Can you guide me on how to accomplish it in OMV6 running Bullseye Lite. after replying to you I found this link:

Do you think it’s the right process?

Yes , those instructions look to be correct although you may want to view the following page that includes a more in-depth explanation of the process : How to disable USB Attached Storage (UAS) - Leo's Notes

1 Like

Great Help. thanks again