Ubuntu 24.04 running on nvme in argon neo 5 odd issue

Hi all, I have just built up an 8 gig rpi5 running Ubuntu 2404lts installed in the neo5 case. Ubuntu is setup with a static IP and in hotspot mode so I can RDP into the rpi5 with my PC or phone.

If I run the nvme drive via USB 3, the hotspot RDP works perfectly.

But when the nvme drive is installed in the case PCIE slot, the hotspot is active but I can’t see it on my PC or phone so I can’t connect and thus I cant RDP in.

Has anyone come across this issue? Any ideas for a fix?

Edit. So I pulled the top cover off the neo5 case and I could see the hotspot but could not connect. With the cover on, no hotspot. Looks like there is to much metal causing the signals to bounce around?? But, how come no issues when booting via nvne USB adaptor? The case is still sealed??

It’s not unknown, that high frequency bus systems (PCIe, USB3, HDMI, WiFi) can disturb each other. But there was also issues in the past with the firmware.


Have you ensured that your bootloader is up to date? 2024-06-05

Hi Harry, thanks for responding. Yep bootloader is current. I updated it using raspberry pi OS. I also ran the argon eeprom script.

I assume these updates stick when I boot to Ubuntu as well? Or should I be doing the bootloader update using Ubuntu?

Edit. Yes it does stick, see image. The eeprom is current.


It looks to me like an EMC problem and you have with the NVMe a jammer near the RPi5’s WiFi antennas.

Can you double check the RPi5 hotspot without any additional cables, dongles and USB devices connected?

The only ways I see to mitigate the EMC problems:

  • Check if there are other transmitters nearby, e.g. DECT phones, USB dongles for keyboard/mouse, wireless headphones, Bluetooth, etc. Maybe the case shielding and the NVMe are just adding issues to an already disturbed WiFi signal.
  • Try a different NVMe model if you have one
  • Improving the shielding of the flexible printed circuit board for PCIe/NVMe connection
  • Change the HDMI cable if the hotspot works without any cables connected
  • Reduce/increase the PCIe Gen1<-Gen2->Gen3 (speed) and check if it makes a difference

Maybe you’ll just have to live with that, because of the rules of physic in combination with the hardware design of the RPi5…

Hi Harry thanks for your detailed response.

No monitor, mouse keyboard attached, no other devices which could affect signal, just USB C power in. I see the hotspot, but I can’t connect. Moved away 5 metres, see the hotspot signal, cannot connect. I switch off the hotspot and I can connect to my home network and web search, update etc. No issues. Wifi router is about 10m away. So only hotspot mode is a no go. Everything else works great.

I pulled the entire thing apart. The pi5 completely outside the case. I just had the ribbon cable attached to boot from nvme, same issue. I see the hotspot, but can’t connect. Switch the hotspot off and no issues connecting to my home network.

I tested with PCIE 2 and 3, same issues. I’ll flash raspberry pi OS and turn on vnc and see if I can connect using that protocol, just waiting for a new nvme drive to arrive.

I don’t have another nvme hat to test with to see it it is the neo5 implementation. The whole point of purchasing the argon neo5 was it had the nvme drive built in and it sits underneath which is very neat compared to other options. Maybe I should buy a hat that sits on top to test.

So I have abandoned the nvme drive for now and just reflashed it to a micro SD card. Booting of the micro SD card with the case completely assembled I see the hotspot and can connect to it and RDP into the pi5.