Trouble with RaspiOS x64 lite instsll

hi all, I am having an issue trying to install the RaspiOS x64 lite for the EON-NAS; I can install just fine on another Pi 4. when I move the SD card to the EON it gets stuck. (see pics). I was able to install the desktop version just fine, but the lite version gets stuck.

any and all help is greatly appreciated.

Are you literally moving the SD card from another pi to the Eon? I’d probably shy away from switching them out like this as there have been slight variations on the “same” model. How about if you burn a fresh card and try that in the Eon? Or swap the Pi itself?

I have tried multiple times and different SD cards. nothing seems to work. I will think about swapping the pi out.

If you think its the Lite try the full Bullseye and see if the RPI works. Even if you have it installed in the EON, just remove the USB 3 jumper plug so your working only with the RPI.

apparently, I have a corrupt Pi 4…

thanks all for the assist.

Have you trid this??? It worked for me.

Go here -

Run this:-


chmod +x install

sudo ./install -n

There was also an issue with the Script. I’ve been on the OpenMediaVault help pages and one of their Dev’s has updated it.

I am now past the Deploying stage.

thanks but i could not even get that far.

From the kernel messages (in the second picture) it appears to be enumerating your attached storage devices (SATA). I would power down, remove the USB 3 dongle (as suggested) and turn it back on to see if you can get past the problem.

If it boots reconnect the USB 3.0 dongle and check your drives. I suspect you may have a bad one.

Are you using the Raspberry Pi Imager?

Are you using Bullseye?

Try that then follow those instructions. That worked for me.