RAID not working with UAS

Hello!

I’m trying to configure a raid 0 array with 4 2.5" drives. I’m using DietPi as OS.
Everything works fine.
When I reboot, I mount the array. But when I try to read/write files, or after few seconds, it doesn’t work anymore. I loose the array and all the drives…
The lsusb commands gives me this :

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And here is the dmesg :
Dmesg error

I tried to disable UAS by adding this to boot/cmdline.txt :

usb-storage.quirks=1741:1156:u,174e:1155:u

I do exactly the same steps as before, no error, the array and drives are still alive.
Here is the output of the lsusb commands :

Bus 002 Device 004: ID 1741:1156 Pinas sata
Bus 002 Device 003: ID 174e:1155 Pinas SATA
Bus 002 Device 002: ID 2109:0817 VIA Labs, Inc. USB3.0 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 2109:2817 VIA Labs, Inc. USB2.0 Hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And here is the dmesg :
Dmesg good

Everything is up to date :

BOOTLOADER: up to date
   CURRENT: mar. 26 avril 2022 10:24:28 UTC (1650968668)
    LATEST: mar. 26 avril 2022 10:24:28 UTC (1650968668)
   RELEASE: default (/lib/firmware/raspberrypi/bootloader/default)
            Use raspi-config to change the release.

  VL805_FW: Dedicated VL805 EEPROM
     VL805: up to date
   CURRENT: 000138a1
    LATEST: 000138a1

The output of cat /proc/version is :

Linux version 5.15.32-v8+ (dom@buildbot) (aarch64-linux-gnu-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022

Is there a solution to use UAS or do I have to keep it disabled?

@TomEighty15 I would recommend verifying on the DietPi forum but for Seagate 2.5 inch (and possibly 3.5 inch) hard drives, disabling UAS will likely be a compatibility requirement (because of the Argon EON’s USB to SATA interface).

Disabling UAS for Seagate 2.5 inch 5TB hard drives is definitely a stability requirement for Ubuntu versions 21.10 and 22.04 (64bit).

@jamesgrace Thanks for the answer
I will try with Raspberry Pi OS when I will have some time.
I have 2 2.5 inch 1TB seagate hardrive, so it may not work following what you said.

Just for my knowledge, do you know why UAS has to be disabled with Seagate hardrive?

@TomEighty15 Take a look at the following pages which provide technical details as well as various
methods to disable:

https://www.smartmontools.org/wiki/SAT-with-UAS-Linux

In my case, I created a /etc/modprobe.d/blacklist_uas.conf file containing the following (note that the values will likely be slightly different for your configuration):

# Disable UAS on Seagate 2.5 inch 5TB Hard Drives
options usb-storage quirks=174e:1155:u,1741:1156:u