Raid creation mounting filesystem on omv

built building RAID1 as suggested from the root prompt via MDADM (4tb, 300mins)
was unable to make FS on RAID device via OMV
made ext4 from command line
FS invisible via OMV cf also Filesystems/config.xml mntent detail at readthedocs

warning in docs that for shared folders to work the devices/fs must exist in config.xml

deleted MD array fro command line (mdadm -S)

rebuilding array with omv CLI omv-mkraid
root@eon:~# omv-mkraid /dev/md/vol1 -N Volume1 -l mirror -n 2 /dev/sda /dev/sdb

Will see if it shows up in the web interface and I can create FS from inside OMV
stay tuned
.
Really Argon, this whole process should have been developed and documented in QA.

What version of OMV are you working with?

I used the mdadm command to build a RAID1 setup.
After that I was able to do everything else through the OMV interface.

Once the drive(s) formatted, I was able to create the shared folder.

The process was a bit kludgy, but that’s really an issue with the OMV docs.

I used the info presented in the pinned RAID topic here, then used the Pimylifeup article someone had posted to finish it off.

6.0.10. (the version installed following the instructions in the booklet)
raid1 built but there are no devices listed in the FS management page to add filesystems to. adding a FS to RAID from the command line is useless as OMV doesnt pick it up.

BR67 lets nut out some doco to give Argon as they clearly arent working on anything.

Can you list the steps you took in this topic

I’m having similar trouble. I created a RAID1 volume via MDADM. OMV can see this volume:

image

However, when I try to create a file system, OMV does not see any devices, not the RAID array nor the disks /dev/sda /dev/sdb.

image

Any thoughts on how to troubleshoot this?

Thanks!

Hello everyone
To me this video helped a lot: first I created the array, then I formatted it in ext4 and omv saw it immediately. (I have 2 4TB disks)

I also had this problem and managed to fix this by ssh’ing into my server and running the sudo mkfs command on the array again, I have no idea why this worked but after I ran it again, I was able to see the array in the Device list of Storage>File Systems>Create.

Hopefully this helps.

Just spent about 3 hours trying to get this to work with no avail.

Followed the video @temeeee posted after using the Ricmedia article and still can’t create a FS in OMV. Anyone having any success with this?

I’ve just managed to get this working, but had issues like earlier people have said. I followed the video, which didn’t work for me, also had the same issues when following the steps in Create a Linux RAID Array using mdadm | Ricmedia.

What did work was using omv-mkraid, specifically I ran sudo omv-mkraid /dev/md0 -N raid1 -l mirror -n 2 /dev/sdb /dev/sdc. I have two identical 3.5 inch hdds which are sdb and sdc for me. I checked what was in /usr/sbin/omv-mkraid (which is an ascii text file) and there were some extra flags passed to mdadm which I didn’t use when I created things manually.

Technically, the manual mdadm steps worked as far as the OS was concerned, just nothing showed up in OMV. I notice that there are a bunch of extra flags in /etc/fstab now that OMV has performed that part compared to what I added manually too.