Questions: LibreELEC M.2 NVME install on an Argon ONE V3?

I just received the new Aron ONE V3 case with the M.2 NVME option. I built the system with both SD and SSD cards installed. After the initial boot, the SSD drive was not visible so I read the directions and tried using the script to enable NVMe. That didn’t work, due to the unnecessary sudo commands. After manually entering the commands in the script without using sudo, the eeprom got upgraded. After a boot, I can now see the SSD drive.

Since my goal is to get rid of the SD card and boot directly from the M.2 MVME SSD, I copied the default LibreELEC 11.0.6 image file to a freshly partitioned SSD drive. When I removed the SD card and attempted to boot off the SSD drive, the console looped with messages about not finding the SD card. I assume there must be a configuration change required to allow booting from the SSD. Is there any info available for how to change the LibreELEC OS to allow the boot? And how get the change installed on the SSD drive (ie. bypass the chicken and egg problem)?

Okay, I got LibreELEC 11.0.6 to boot off the SSD drive without an SD card. I took the SD card that I’d used to update the eeprom, used win32diskimager to make an image file and then used the same app to write the image file to the SSD. The system booted but the “storage” partition was limited to the partition size from the original SD card. I tried to force LibreELEC to resize the partition, but that didn’t work. I then used the “parted” command from an ssh session to resize partition, and then the resize2fs command to expand the file system to use the expanded partition.

resize2fs /dev/nvme0n1p2