Pi4 Argon One M2 - /dev/lirc0 troubles - Solved!


So i’ve recently been tinkering with my Pi4 in an Argon One M2 case and had been unable to get the IR reciever working again.
Previously I had an image with it all setup and working and don’t remembering it being too difficult to setup, but this time round try as i might I couldnt get /dev/lirc0 to show up as a valid input and therefore no response from mode2, irw, irrecord etc.

I do recall last time prior to getting it working it hadnt just worked with the out of the box setup script but did work with the osmc version:
curl https://download.argon40.com/argonone-setup-osmc.sh | bash

But this time round even the osmc version of the script wouldnt work (not only due to outdated python dependencies).
So after a lot of trial and error (and enough reinstalls to probably corrupt the SD card) I found a forum thread over at the OSMC forums which indicated there was an OSMC hardware configuration (ie /boot/config.txt) option to enable IR remote support which I dont think existed the last time I checked.

Anyway with that setting enabled it added “dtoverlay=gpio-ir,gpio_pin=23” (which I had already setup) but there were further options added which i’ve just tested and were in fact the required config.txt options to enable OSMC to respond to the Argon One M2 IR sensor.

So the /boot/config.txt options which were added:


I tested this on a fresh install, modified the config.txt, rebooted and pointed the osmc addon remotes at the correct conf file and boom, remote support back again.

So for future reference or anyone else out there who is struggling to get an lirc socket to initialize, try making this change in the osmc tool or adding manually.

I had tried a lot of stuff, modules, modprobe, lirc/hardware.conf, lirc/lirc_options.conf, killing lircd_helper@lirc0.service, manually opening a socket anything I could find with reference to lirc before I found that reference to additional config.txt options i wasnt aware of.

So I think Argon need to update their setup scripts for the PI 4 as I think “dtoverlay=w1-gpio-overlay” needs added in addition to “dtoverlay=gpio-ir,gpio_pin=23”
Also there are python2 dependency errors.