Pi upgrade issue

I have my Eon running OMV perfectly using a 4gb Pi4.
I’ve swapped out the Pi for an 8gb model for my containers to make use of the ram.
I read that moving the OS(running on a thumb drive) from Pi4 to Pi4 should have worked without any need for config, but it is not longer getting connected to the network anymore.
The script is running on the screen (which indicated to me the OS is indeed running in some form), but the connection settings are showing N/A and I cannot see it on my network anymore.

Has anyone got any ideas on how I can save it?


I’d double check your boot order settings and better yet your rpieeprom and boot loader. This has happened to me in the past and it’s been because of inconsistencies in those settings. Best path forward for me was to write an SD card with raspian, setup the new board with it. Do an update, upgrade, and full-upgrade. Then use raspi-config to change the boot order (assuming you’re booting off USB/M2)

What id guess happened is your old board is out of date (or vice versa with your new board) bios/bootloader-wise and the file system is not being read properly, causing the OS to not start, which prevents the interfaces from coming online.


You absolute hero, thank you!
I’ll have a look at that later today. It’s definitely the most likely thing and I overlooked it.
The 8gb Pi has been configured for usb booting, but that was done a long time ago.
I’ll try another card to update it like you suggested.

Thanks again!


So I managed to save my install!
Updated EEPROM, but this didn’t not do anything other than stop the screen from functioning.
I did a bit of a dive into the startup config via the hdmi out, and it was hanging at the networking part.
Further inspection showed all files related to eth0 or networking simply didn’t exist.
I was able to restart eth0 and I finally got an IP address!

It now works and the extra ram has been picked up, so now i just need to bring the screen back to life; its currently displaying the first few rows of pixels and thats it.

1 Like

I have had an issue where the OLED sometimes glitches upon boot and only displays approximately the top 6th of the screen with the rest blank. This includes the initial boot logo as well as the information displays. Any text that is shown in that remaining 6th is legible. I found that if I powered down the system, unplugged the power, then plugged it back in and rebooted, the screen would work again.

1 Like

I shall try this tonight, thank you buddy!

It worked!
4gb RAM to 8gb RAM upgrade now officially successful.

Thanks for the help!

1 Like