Persistent Undervoltage with Argon One M.2 Case

I’ve had the main case for a year or two now, and decided to upgrade to the M.2 SATA SSD case in April. Since then I’ve had troubles with sporadic, but persistent under voltage problems. So far I’ve tried the following:

  • Buying and using the Argon 40 15-watt power supply
  • Turning off overclock
  • Buying and using a powered USB hub for any peripherals.

To no avail. At this point there are three potential problems: something wrong with the Pi or v2 case (doubtful, worked fine for over a year, problems started upon install of the M2 case.), something wrong with the M2 case and board itself, or something wrong with the SATA ssd.

I think it is the result of the SSD pulling more power than the Pi can provide through its USB ports, which discussions about the product on the raspberry pi forums have mentioned as a concern.

Has anyone had any similar difficulties? What SSD do you use in your setup? I am using a 128 gb Transcend MT430S SATA SSD and I can’t actually find any helpful information on how much power it pulls (only voltage- no amperages).

I’m very frustrated with this because there was no indication that this might be a problem anywhere, and now I’ve sunk an additional $50 trying to solve it.

…and now having researched it, it seems like a flawed product even in concept since the Pi can only put out 5v/1.2a (6 watts) over its USB port and some M.2 SSDs can pulling more than that, with little that can be done to determine whether an SSD is “compatible” beforehand.

1 Like

I’m using an ARGON one case… and added the M.2 expansion case about 6 months ago. I have not had a single issue, running KINGSTON SA400M8120G…

Didn’t need more space, currently hosting an instance of pi-hole and a custom script to monitor the network. Not much else going on. zero under voltages.

@dandrewe If I am reading this correctly, the 15-Watt Argon40 PSU is a micro-B design - so you are likely going through an adaptor of some type.

Are you able to measure the voltage going into the board at the tip? You’ll likely observe it being something less than 5V.

If you are unable to test that, perhaps you have (or know someone that does) either an official Raspberry Pi USB-C PSU or the Argon40 USB-C PSU?

Worth asking as 99% of the time, this solves the issue. Those hefty power cables keep the voltage drop minimal and assist with better current delivery and faster voltage corrections.

Basically all SATA drives should be fine, though some performance-grade NVMe drives can exceed the 5V headroom.

I am also using an Argon One V2 with M2 case addition. Using a Kingston SA400XXXX (not sure about other numbers but it’s around 120ish Gb). That is about all the official Raspberry PI power supply could handle. If I plugged in extra load into the USB port(s), the logic circuit(s) wouldn’t work and got corrupted. I did the powered USB hub (Startech HB30A10AME) thing… and I can plug in what I want within reason. I used the industrial 10 port model… not cheap. (But very, very good… there is also HB30A7AME for a 7 port hub)

Anyway, you commented that you were unsure if your SSD was dragging the normal power supply down… hmmmmmm. As an experiment, if you have 1 or 2 spare POWERED USB hub ports left over, remove the Argon one/M2 usb connector (the little U shaped USB connector plug), and connect both sockets to to the hub. THE HUB WOULD THEN BE POWERING THE SSD… you would need a couple of USB connector cables… keep as short as possible. Anyway, that experiment should tell you if your SSD is making your problem… (This would leave your current PSU powering the Argon One Case and Raspberry Pi only) The M2 with SSD would be powered from your hub…

Or change to Kingston SA400 series M2 Sata, as I notice another reader is also successfully using that memory… sort of depends what the cheapest solution is.

Added a NVMe drive and set it up to boot from. Added 3 hard drives over powered USB. Used the Argon ONE USB C maximum power supply. Upgraded to ZFS for testing and turned off cache as well. Everything technically boots and it might be related to USB 3 bandwidth or how the RPi handles things but feels more power related.

Got so many hardlocks, random reboots, complete freezes on both RPi and Ubuntu that you literally cannot SysRq REISUB and all sorts of ZFS issues on multiple hard drives at once despite them all being brand new for testing that I finally gave up and moved away from using a RPi for much of anything except simple tasks. You should not have issues sending fairly basic anything over USB 3!

There is a reason Argon 40 delayed their NVMe board by months and months. It’s because NVMe can use way more power than the RPi 4b can literally provide. Period. Now you can technically set the power mode lower and you can technically use lower power NVMe but not all of them will do that and most customers will never know the difference and expect it just to work.

I have multiple Raspberry Pi 4 (8GB) setups each housed within Argon ONE M.2 cases (with the Argon ONE 18W 5.25V 3.5A USB C power supply) along with Western Digital 500GB WDS500G2B0B SSDs and have experienced zero issues.

I have same issue … please can anyone resolve?

Excuse me for the late reply! Having looked through my purchase history, I found I misremembered which power supply I was using.

I started out using the official Raspberry Pi USB-C power supply, but now I am actually using a canakit 3.5 amp power supply. I had intended to purchase this one, but if my memory serves I couldn’t find it on amazon, and went the canakit route since it is rated for 18 watts as well.

Since I last posted in this topic I’ve done a few things.

  1. I made sure that everything was connected to the same circuit to eliminate the possibility that there was some kind of weird ground loop problem going on

  2. I decided to switch to a Kingston SA400M8/120G (now using the original SSD was a flash drive with an enclosure) since @Fustercluck indicated that it worked for them and another user.

  3. I also used a USB 3.0/C compatible USB voltage tester plugged in between the Pi and the power adapter, and I didn’t see any periods of time where it dropped under 5.1 volts (though it provides readings every 1s or so, so I can’t spot any very short spikes with it.)

I’m happy to say I’m not getting random brownouts the way I was, but I am still getting undervoltage warnings from hwmon on and around boot, and I’m still having another issue:

I’ve discovered that I’m often unable to boot without unplugging the USB hub (occurs with both hubs I own). As far as I can tell it’s been like this since the beginning, but didn’t put together that I always had to unplug just the USB port- when I had trouble booting I would unplug everything as a matter of course.

The red power light will come on but the green activity light does not until whatever is in the second USB 3.0 port is unplugged, then it starts booting properly. I’ve noticed at times during boot the red power light goes on and off while the activity light stays on-- I’m not sure if that’s normal or not.

At this point I’ve changed out the SSD (to one that’s worked for other users), the USB hub (to a powered one), the power adapter (to one with an 18w capacity), even the power strip and the circuit that everything is plugged into. All that leaves is the M.2 module, the case, and the Pi itself. The Argon One case and the Pi were not having these issues before installing the M.2 module, so all I’m able to conclude is that it is probably some sort hardware problem on the M.2 module.

I’m within 90 days of purchase, so I’ve contacted the Argon 40 Amazon store about a possible replacement.

HI Dandrewe, I’m pretty sure that Raspberry Pi 4 with the Argon V1/M2 case set up is recommended for SATA M2 drives only.
There is a large variety of memories that fit into M2, or are classified as M2.
M2 simply refers to the physical connection, and PCB size.
You can plug an MVME or SATA into them if they have a M2 plug on the board. I think (but I am not 100% certain) that SATA memories use less power than MVME’s.
Anyway, as I was under the impression that these things are designed for SATA, and that’s why I used the Kingston SA400, cos I had a spare one. NO problems. I tried a NVME (Crucial P5?) and things didn’t go well… at all. SO back to the SATA device and closed the lid, and I am still using it. And using as quality powered USB hub for all other crap that I tend to connect to my PC’s.
Less power use by your SSD or USB peripherals means that your PSU for the Pi4 is not being dragged down, or getting voltage spikes… that’s why I have the Pi PSU powering the Pi and the Kingston SATA SSD only… everything else to the powered USB hub. Good luck

@Fustercluck You’ve misread my post. I’m well aware of the difference, so I never used an NVME drive. I can’t imagine the thing would ever boot with an NVME drive

Here are both drives I have used, both are SATA M.2

Transcend

Kingston

I am literally using the Kingston SA400 you identify as working, right now

I have received a response from the Argon 40 customer support on amazon. It was less than helpful.

Here’s the image. argon 40

They have indicated that they believe the issues are stemming from an inadequate power supply (not the case, something I addressed within this thread) or from an SSD drawing too much power (something I’ve also addressed by using the same SSD as @Fustercluck, and contradicted by @CoreElectronic’s statement that “Basically all SATA drives should be fine”)

I find the second reason interesting because it indicates that this is a known problem- it can only support certain SATA drives. This is a limitation that is undisclosed on the amazon product page as of the time of my writing.

Needless to say, if there had been something on their product page stating “this might not work with all SSDs and No, we won’t tell you which ones it will work with” I wouldn’t have bought it.

It’s a damn shame because I really like the case itself, but this M.2 board is less than half baked.

I have a couple of the Argon ONE m.2 cases.

One has a 500GB WD Blue m.2 SSD, the other has a 240GB Kingston m.2 SSD.

Both are powered by the 18W Argon ONE Power Adapter V2 USB-C (5.25v, 3.5A) adapters.

No power issues with those combos.