OLED Not Working

Received my EON today and promptly mounted the Pi4 8GB board loaded with Raspbian (Bullseye), OMV, and MDADM.

Everything installed without issue. I do however have no OLED readings. Power On/Off function words but no display.

Can someone please instruct me on how to get this working?



I found a website that helped.

Now I have to figure out how to invert the OLED information. It currently is upside down. Any help would be great.

Have you actually installed the Argon EON utils that runs the display / fan / RTC etc.?

curl https://download.argon40.com/argoneon.sh | bash

Then argon-config from a terminal to get the config options.

Hi upon power on, there should be a logo that would be loaded on the OLED module. If the oled does not display anything, would suggest try to check the cable on the OLED module and the power board.

The EON Icon shows on power-on. This is not the issue but rather the information once Pi has been booted.

Thanks for the info.

I installed the script as posted above and rebooted.

So now it reads the EON information BUT it is reading it upside down and from right to left. Weird.

How do I fix this?

I was having problems with the OLED too. When I would power on I would see the logo but nothing else. I tried to use argon-config to change the setting but nothing worked.

Using raspi-config, I made sure that I2C and One Wire were both enabled. I think you just need I2C but it didn’t seem to hurt that One Wire was enabled.


Used the option to uninstall argon-config from the menu.


Reinstalled the Argon script:

curl https://download.argon40.com/argoneon.sh | bash

Configured the display with argon-config.

Started working like a champ!

I guess it was an I2C issue

1 Like

As of today, I wiped my OS and rebuilt it with Raspberry Lite (Bullseye) and installed the Argoneon.
OLED is now displaying correctly.

Looks like I2C is disabled by default on DietPi, enabling it fixed both the screen and fan control for me!


Hello, i have my argon neon since 10 days now, and i tried bullseye lite and desktop, i also tried buster. I have installed the script everytime and the oled never worked.
I don’t have the logo at start.
I checked the cable, rewired everything but to no avail.

@worax34 in case have tried the troubleshooting steps, please email cs@argon40.com, we will try to ship you a replacement OLED module when our operation resume in China on the 3rd week of Feb.

I have the same problem. I have tried bulleys OS 64 lite and Buster Desktop and Bulleyes 32 bit lite and still no OLED or fan or RTC. I have only had the system for about a week and it did work in the beginning, then started having trouble. I have checked all the cables and everything seems to be in place. My order number is:argon40
ORDER #1130

Thanks for the heads up on this! Same thing happened to me.

@Nellisoft, @Kylo.Henny could someone using DietPi post the results of:

cat /etc/os-release

I’ll update my script to detect it and turn on I2C


1 Like

Sure. Here ya go:

PRETTY_NAME=“Debian GNU/Linux 11 (bullseye)”
NAME=“Debian GNU/Linux”
VERSION=“11 (bullseye)”
SUPPORT_URL=“Debian -- User Support


With the 64bit version of DietPi works with my script and no changes. You MUST enable I2C prior to installing, and should reboot before.

I installed and ran the script, and it worked… Did need a reboot however.

1 Like