OLED Display Malfunction


After setting up my EON using latest Raspbian Lite and installing the Argon EON script, it worked great for a few hours, however the OLED display has malfunctioned now and shows vertical lines. The rest of the components work fine. I did not modify the argon-config in any way.

Following is a photo taken when Argon EON boots up. It used to show the Argon EON logo previously.


And the following is a photo of the display taken when it should be displaying the CPU temps and CPU usage screens, but it’s just vertical lines and blocks instead.


1 Like

Hi Nilayk

Normally this kind of problem is caused by loose connection. Can try to check the wires connected to the OLED Button module and the wires going to the main power board. If this does not resolve the problem, please help email cs@argon40.com, we will arrange a replacement of the OLED button module upon resumption of our factory’s operation in mid feb. The oled screen won’t affect other functions of the unit.


I have an issue with my OLED too. It displays the Argon Eon logo, but remains blank after booting. I installed OMV onto raspian and ran the script to install the Argon configuration. The menu selections look like it should be displaying all pages, but the screen remains blank.
I’m going to try a fresh install but any pointers would be appreciated.I’m booting from an SD and two 4TB drives are up and running. I created a share and users to test and all the rest seems great.

I have had an issue where the OLED sometimes glitches upon boot and only displays approximately the top 6th of the screen with the rest blank. This includes the initial boot logo as well as the information displays. Any text that is shown in that remaining 6th is legible. I found that if I powered down the system, unplugged the power, then plugged it back in and rebooted, the screen would work again.


Yes, I think the issue was with the loose connection. I removed the cable from the button module and the main board and reconnected them. That addressed the issue and the button OLED display works as expected again.

Thank you.


Hi Mik3789,

The OLED screen should display a logo even without the script installed. It might also be a case of loose cable connection. Please help check the cable on the oled module and the power board.

I have the same problem, and the fan is also ignoring any customization/always running at full speed… tried reconnecting the internal cables but there was no change. I am using the 64-bit version of DietPi, however, could that be the issue?

I just experienced this for the first time … I’m trying your solution now. Thanks!

EDIT: No dice. :frowning: Still missing everything but the very top of the display. It’s not corrupted. I can read what’s there just fine. I haven’t touched it in weeks, and it was working before, so I doubt it’s the connectors, but I’ll try unplugging them later. Are they keyed so I can’t plug them in backwards? :stuck_out_tongue:

… I wish I had smaller hands.

EDIT: Fixed. I’m not sure how. I didn’t unplug and replug the connectors.

I did try unplugging the whole unit again, except this time I also unplugged the ethernet cable, because the port can blink even when the unit isn’t on, which means there’s some minimal amount of power there.

Left it unplugged overnight and now it’s fine.

I have noticed that too, intermediate problem between off / on…when it does happen leaving it off a little longer seems to fix it… very annoying behavior.
my is fairly new… like 1 month … :face_with_diagonal_mouth: