NVMe drive not showing with Argon 18W charger

I just received my NVMe expansion board a few hours ago and spent the said hours trying to get it to work. Besides the board having incorrect firmware, as reported here, it seems my 2TB Silicon Power XD80 NVMe doesn’t show up in OpenMediaVault. If I use a different charger (65W, don’t know about the cable but it’s from my Pixel5), it sometimes shows up at half capacity (1024MB) and sometimes shows up correctly.

However, when it does show correctly, whenever I try to mount the filesystem, the drive disappears and OpenMediaVault throws an error.

When this happens, it takes multiple restarts / unplugging the usb connector to finally get it to show up again.

I’ve waited for almost a month for the package to arrive and I’m quite disappointed with the outcome. I’ve had the Argon One V1 for a few years and really loved it. I’d have expected this new one to work flawlessly.

I’m now waiting for an aknowledgement and fix from Argon for the firmware part, and hope the other issue I have will somehow magically get fixed as well.

I also have an EON on the way, I hope that one works as expected.

I just tried a 1tb Samsung nvme drive and it seems to work without issues, connected to my laptop’s 65w charger. With the same charger but 2tb nvme, the issues persist. So I can’t exactly pinpoint the problem. I thought it was power related, but that doesn’t seem to be the case.

Ok, so I finally got it to work. It somehow just fixed itself. I just kept fiddling with the drives and at some point OMV took a very long time to apply changes. After that, the drive showed up and I was able to mount the filesystem and create the shared folders. I am now running the pi with the 2tb nvme drive and another 2tb hdd in an attached usb 3 enclosure. I am using a Lenovo 65w laptop charger.

Just need to wait for a firmware fix from Argon.

It seems my setup was not very stable. As I was running the pi headless, I finally(!) got the idea to attach a display to it to investigate potential issues. It seems I was getting lots of Undervoltage detected! errors. So I read the fineprint on the Lenovo charger and, to my dismay, the 5v output was only 2A!! I’ve now come back to the supplied Argon 18W charger and… it works. It’s bonkers. I’ve spent so many hours trying different settings and chargers and now I’m back to the intended original setup.

I really hope this is the end of the story.

1 Like

So… my problems persisted.

I can now say I’ve finally identified the issue. I apparently have a defective case power connector. Whenever I move the cable or case, I either get a reboot or a shutdown. I’ve now reverted to using my V1 case and the random shutdowns/reboots disappeared. The V2 case has a much quieter fan though, and unfortunately the fan connectors aren’t the same - which prevents me from replacing the old case fan with the new one.

I tried finding a replacement board for the case, but it doesn’t seem they are sold separately.

Hi @novemberbreed , can you help send us an email at cs@argon40.com so we can request for a replacement power board to try to fix this? Thank you!

I upgraded my power adapter to 120watts for my Argon EON tower (running 18tb of M.2 NGFFs combined), even if u get it to work with 18w you will have unpredictable problems such as m.2 goes offline randomly, network drops your file copy instances. Also check max CPU frequency , start with low default and steady increase max limit every 24hr

If you wish to try bigger wattage universal power adapter, make sure you get matching Voltage rating from your factory power adapter but with more amps.

Watts = Volt x Amps

Hello @kenneth. Thanks for reaching out. After full disassembly of the case and reseating of all parts, I stopped getting shutdowns and reboots and it’s been running pretty stable for about 5 days. So no reason for now to ask for a replacement anymore.

Like @Dracwula mentioned though, it is not entirely without issues. I still sometimes get “Undervoltage detected” errors (at one time causing the filesystem to remount as readonly), even after going back to 1.5GHz from the overclocked 2GHz I was running at previously.

I am using thermal compound instead of thermal pads on my Pi4 CPU surface, several mentioned they had found their thermal pads did not contact the heat sink, please double check that too.