Need to remove and then connect USB3 bridge to boot after installing M.2 SATA drive

After installing an M.2 drive, formatting and configuring the drive for booting from it, after cold power up the Pi will not boot and no display. If I disconnect the bridge before power on I see display indicating that it is looking for USB boot, and if I then connect the bridge the Pi boots normally. Pi functions normally thereafter. If I reboot, or shutdown and then boot, this issue does not appear. Only after disconnecting power the issue resurfaces.
Pi4, 8 GB RAM, 64-bit Pi OS up-to-date:
Linux raspberrypi4n 5.15.61-v8+ #1579 SMP PREEMPT Fri Aug 26 11:16:44 BST 2022 aarch64 GNU/Linux

I assume this is not expected. Has this been seen before? Any suggestions or possible fix?

Can I ‘Assume’ that you have installed the OS wanted using the Raspberry tool “Raspberry Pi Imager” to do so without any reported errors, and then removed the SD card before rebooting ?

These are the steps I used to install Bullseye X64.

I booted from the Pi OS image that enables booting from USB (created via “Raspberry Pi Imager” ), then replaced my original SD, booted, and copied it with the SD Card Copier utility to my M.2 SATA drive, shutdown, removed the SD and rebooted. No issues, other than as I noted: need to remove and replace bridge during cold boot, but warm reboot works without needing this unusual step.

Sounds like a correct method, although I do it with a step or two shorter i.e.,:

  1. Install Imaging s/w to laptop.
  2. Download and save OS (to be used) image.
  3. Remove USB bridge between Pi and drive dock.
  4. Connect USB-3 cable to drive dock and donor compuler (e.g., laptop)
  5. Optionally format drive to Linux format and set up swap partition at end of drive with 4Gb.
  6. Run imager to directly install OS.
    When complete, disconnect USB cable and reconnect USB bridge.
  7. Boot the Pi having already connected any other needed cables for the task such as HDMI (monitor), LAN.

That’s it and I do not use wifi as signal is not so good as a wired Lan connection.

I did first try with Ubuntu desktop but it locked up after fully booting up when I tried to lead a terminal program. Ditto with Ubuntu server but works with Bullseye (Make sure you are using X64 bit version as performance is slightly better depending on the tasks running.

The only note I can say is that the imager has its own way of setting up the drive prior to leading and configuring the OS and this ‘might’ lead to being a total drive formatting but the use of a swap file is very useful even with 8Gb Ram but this does involve possibly changing /etc/fstab to have it mounted on boot.

Note the above steps did not use a SD card but I did load up a SD on the laptop and install the OS direct to it via the imager as a back up ?? and no I have not used it !

After setting up the Lan connection and confirming connection say via the web browser do a OS update using (sudo apt update,) sudo apt upgrade -y
Warning there will be a lot of updates and it WILL take a while.

I have the same problems, after a shutdown when I try a cold start of my Raspberry pi 4 (8Go) green led does not blinking and Raspberry does not start on M2.
I need to remove Usb bridge then green led starts blinking and reconnect Usb bridge to start booting on M2.

I have used Imager to install OS

After that Raspberry pi 4 works well.
A reboot works without problems.

Have you found a solution ?
Thank you for help

Pi4, 8 GB RAM, 64-bit Pi OS (update ok)

I found this solution which works for me.

Isolate this contact (see picture) from the raspberry pi board. You can do the test by putting a sheet of paper between the raspberry pi board and the m2 SSD disk board, close the case, reconnect the cables, Usb bridge and start the Pi.

After I put a small piece of thin plastic to prevent the contact from touching the card.

I first tested the open rasberry pi using a male male type usb cable instead of the bridge. Then closing the box I had the problem again, even with the cable.

CarteM2

1 Like

Very good!
This works for me too. I put a small piece of isolating tape on the pin.

Is there anyone from Argon monitoring these forum posts?
It would be nice to understand what this pin is about, and if there are any unintended consequences for isolating it.

BTW. I notice you have the nvme board - I instead have the SATA board, but which also has a similar pin.

:+1:

Yes I use a
WD Red™ SA500 NAS SATA SSD 500GB
Reference: WDS500G1R0B
Capacity: 500GB

I would also be interested in the usefulness of this piece.
Is this forum followed by the manufacturer so that he can answer us ? …
WDssdM2_500Go

Sam57 is right on the money.
The reason this pin is causing issues, is because it directly makes contact with pin TP2 located on the bottom of the Raspberry pi 4 PCB.

TP2 is connected to the 5V rail of the USB PSU, so when the supplied USB bridge connector is connected to the System it is creating a short in the circuit, because USB supplies 5V anyway?
strangely the probe is only present on more modern revisions of the m.2 PCB , mine being v2.3 for example, the older versions: v1.x did not have this probe.

That implies that argon40 thought that the ssd caddy needed a constant 5v at some point down the chain.
I personally can’t fathom why.
The Pi not booting as a result of the short is a safety feature, so this would need to be fixed at the firmware level of the pi4, until then small bit of tape over the pin on the pi.

Quoting from here:

Argon40 have addressed this by the addition of a pogo pin on the Argon ONE NVMe expansion board which contacts with a test point TP2 on the underside of the Raspberry Pi 4 PCB, which in turn is connected to Vcc (5 Volts). Thus allowing the Argon ONE NVMe board to be powered without the power limitations of the USB interface.