How to install Argon One Fan HAT. I can't

I can’t install the Argon One fan hat. with Script [curl | bash ]
I Enable all connections (i2c, SPI, Serial) But I can’t install it. It’s Stack this screen. And I can’t do anything.

I had the same problem recently when installing the fan control install script on Raspberry Pi OS 64bit. What this reddit user suggested worked for me, Reddit - Dive into anything

1 Like

I’m stuck on the same issue. Sadly the reddit comment got deleted… Could you please share the solution here? Thanks!

Hi, I just downloaded a fresh Raspberry Pi4 64 bit image and ran the script without any issues.

I’m Happy to try and troubleshoot and fix if you can provide more info on your system you’re having problems with.

OS: Debian GNU/Linux 12 (bookworm) aarch64
Host: Raspberry Pi 4 Model B Rev 1.1
Kernel: 6.1.0-rpi4-rpi-v8
Shell: bash 5.2.15
Resolution: 3440x1440
WM: wayfire
CPU: BCM2835 (4) @ 1.500GHz
Memory: 1700MiB / 3793MiB

Hi there, I also flashed a fresh install of latest Raspberry Pi OS Lite 64bit on a Pi Model 4B (directly on a ssd I use instead of an SD card). Then I tried to install the script via SSH, but can’t confirm nor deny the prompt. It just gets stuck on the screenshot above.

Got any idea what the issue could be? Thanks!

I just downloaded the 64bit lite version and tried again and “it just worked”.
I can see that the query about enabling login shell over serial is shown when configuring the serial interface option in raspi-config. The only call to raspi-config in the script is:

sudo raspi-config nonint do_i2c 0

This runs raspi-config non-interactively and should enable i2c. But I don’t understand why the serial UI config UI would come up.

I’d suggest those having a problem download the script:

chmod +x

edit the script and remove the line sudo raspi-config nonint do_i2c 0, and try and enable i2c manually instead. Save the file and then run the script: ./

If that doesn’t work, then there is some other part of the script triggering raspi-config to run.

Also ensure you’re running the latest scripts, I think older versions of attempted to configure serial and i can see the latest has some special handling for serial for the bookworm release and for detecting the RPi5. If the script you’re using contains something like sudo raspi-config nonint do_serial 2 then that will trigger the experience reported earlier.

Script is broken
Can a new one with the fix be uploaded?

I was using the files linked and unable to reproduce. Unless there is a CDN serving an old file I can’t see what would cause this.
If you can download and check the script that would be helpful.

I have one working on a Pi 4b 8Gig running 32-bit buster and it works great. I just purchased the Fan Hat for a new 8 Gig running 64-bit Raspbian and it fails completely - the fan won’t even run. (I2C is enabled.) When I uninstall the script and reboot the fan runs in the default 50% setting. At least it runs then.

The script indicates it has installed everything, but I don’t even get the Icon on the desktop. Running the config script makes no difference. For now I’m just leaving the software uninstalled to keep the fan going.

I wish the script would indicate what version it is so we could tell when it is updated and so could try again. This shouldn’t be that hard.

Just got my Argon One M.2 case delivered.
(I didn’t realize it was the non nvme m.2 one - big sadz…)

So with regards to this script not working - what do you get thrown out in the shell?

I just setup the argon one shell utility on buster, bullseye and bookworm to test on my pi (using fresh installs) so that means you might have something installed that uses a conflicting version of a library.

I’d recommend always starting with the latest versions of software:

sudo apt update
sudo apt upgrade
sudo rpi-update

Then try running the argon one install command again:

argon-uninstall # try to remove if it is installed
curl | bash

Do that as root though, so make sure to swap to your root user:

sudo su root