Fan Issues on Fresh Install (Raspbian Lite 64-Bit): Fan Blasting + Unable to Set RTC

Hello,

I could use some help with a fresh install. I used Raspbian Lite 64-bit on an 8GB Raspberry Pi 4 with the latest beta firmware (this one is set up for net installing the OS–which was useful in this case as I forgot to flash the NVME before I inserted it and closed up the EON).

Everything seemed fine until I installed the eon script using the instructions in the manual. (Fine in the sense that it saw all my drives, at least.)

I installed the coin-cell battery with the positive terminal facing up (into the open air).

  1. After the script installed, the fan immediately went to full blast. It’s loud, and doesn’t seem responsive to temperature. I haven’t adjusted the default settings. It sounds like it’s trying to lift off.
  2. I also can’t adjust the RTC’s time. It thinks it’s sometime in 2080, and doesn’t react at all when I tell it to update the time.

EDIT: Additional info:

  1. Fan is oriented to move hot air out of the top of the case;
  2. Battery photo attached.

Any ideas?

A52979AE-0198-474F-BD5B-3D39E8954546

I don’t know if I have the same issue as you, but it does sound at least to be similar. Check the bottom of the Extended OLED thread.

Thanks, @jet438 . :slight_smile: I’m seriously considering switching to Ubuntu server. There’s something about Raspbian that just rubs me the wrong way, honestly. It didn’t let me go through any sort of setup process, and just dropped me into an auto-logged in prompt. Insecure and confusing.

I suppose I could just install OMV on it and go, but initial setup feels unfinished.

So. Something odd has happened. It’s actually working better now, after having left it off and unplugged for 24 hours. I’m not sure why.

  1. When I first turned it back on, the fan didn’t immediately start blasting, which is new behavior.
  2. The fan eventually came on, and is loud, but I can actually hear it ramping up and down. It’s adjusting itself based on temps and using a very aggressive fan curve. I’m not sure whether it’s using the CPU temps or HDD temps, and don’t really know how to get this information without altering the fan curves.

Problem:
The RTC is definitely still not working. We’re still in 2080, apparently.

EDIT:
I may in fact be an idiot. For some reason, at least according to htop, the system time (which the script reads to adjust the RTC), is January 6, 2080. So, I need to fix that.

EDIT 2:
Fixing that is proving more difficult than anticipated.

Systemctl is giving me some odd output.

$ systemctl status time-sync.target 
● time-sync.target - System Time Synchronized
     Loaded: loaded (/lib/systemd/system/time-sync.target; static)
     Active: active since Sat 2080-01-06 18:39:05 CST; 25min ago
       Docs: man:systemd.special(7)

$ systemctl status time-set.target 
● time-set.target - System Time Set
     Loaded: loaded (/lib/systemd/system/time-set.target; static)
     Active: active since Sat 2080-01-06 18:39:05 CST; 25min ago
       Docs: man:systemd.special(7)

Jan 06 18:39:05 eonnas systemd[1]: Reached target System Time Set.

I’ve never run into this before. Not sure what to try next.

EDIT 3:
Okay. My lack of familiarity with Raspbian is showing. I wasn’t asking the status of the correct service.

$ systemctl status systemd-timesyncd.service 
● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2080-01-06 18:40:40 CST; 28min ago
       Docs: man:systemd-timesyncd.service(8)
   Main PID: 844 (systemd-timesyn)
     Status: "Idle."
      Tasks: 2 (limit: 8985)
        CPU: 306ms
     CGroup: /system.slice/systemd-timesyncd.service
             └─844 /lib/systemd/systemd-timesyncd

Jan 06 19:04:14 eonnas systemd-timesyncd[844]: Timed out waiting for reply from [2604:4300:a:25e::202]:123 (2.debian.pool.ntp.org).
Jan 06 19:04:24 eonnas systemd-timesyncd[844]: Timed out waiting for reply from [2607:fa18:3:88::35]:123 (2.debian.pool.ntp.org).
Jan 06 19:04:35 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 162.19.154.87:123 (2.debian.pool.ntp.org).
Jan 06 19:04:45 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 216.229.0.49:123 (2.debian.pool.ntp.org).
Jan 06 19:04:55 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 50.205.244.111:123 (2.debian.pool.ntp.org).
Jan 06 19:05:05 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 45.33.68.112:123 (2.debian.pool.ntp.org).
Jan 06 19:05:16 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 162.159.200.1:123 (3.debian.pool.ntp.org).
Jan 06 19:05:26 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 12.167.151.1:123 (3.debian.pool.ntp.org).
Jan 06 19:05:36 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 74.207.242.234:123 (3.debian.pool.ntp.org).
Jan 06 19:05:46 eonnas systemd-timesyncd[844]: Timed out waiting for reply from 204.93.207.12:123 (3.debian.pool.ntp.org).

Well, that’s pretty straightforward. It can’t talk to Debian’s time servers.
Between this and apt-get not being able to update its package lists, I’m starting to get concerned that something is wrong with this install. Either that, or something is wrong with the Debian servers.

Have you tried raspi-config? I believe there’s a setting for date and time. As to RTC, I’ve never used it. My servers are constantly running and I’ve never had an issue with what the date and time is.
As far as Ubuntu versus Raspbian is concerned. They’re both basically the same on our end.
You fan cycling sounds like a matter of setting within the argon config file. happens more often than I’d like to admit in construction when a BMS contractor puts the set points in in such a way that the program is telling the fan to both turn on and turn off at the same time.

I’ll have to look at raspi-config again. Thanks!

I tracked the problem down to the service that’s supposed to update the system time when the Pi boots. It’s hitting Debian’s time servers, and they’re not responding. Debian’s apt-get package list is also not responding correctly, so something’s up there.

My understanding of the RTC is that it sets its own time via whatever the Pi’s set time is, and knows what time it is when the Pi is off, so the unit can turn the Pi back on at a set time. Not something I’d use much beyond just making sure it actually works.

I realized it was holding all the HDDs and SSDs in the 30-45 C temperature range, which is ridiculously low for enterprise-grade spinning HDDs in such a small space. I’m fine with running them at 50-60 C (my QNAP 2-Bay keeps these drives at 53 C when idling, and 60 C under sustained load, and calls it good, so that’s my target), so once it’s working again, I’m going to try to adjust the fan curve to be less aggressive.

The case itself is a giant passive heat-sink, so I’m guessing that whatever active cooling I do based on the HDD temps will be enough to keep the CPU from throttling, which is all I really care about. Given the ventilation situation, as long as the CPU didn’t regularly go past 70 C, I’d think things should be fine.

At the moment, I’m not doing anything else with it, since the PSU died. :stuck_out_tongue:

You need to use the RTC function within argon-config to get the RTC set properly.

pi@ArgonEON:~ $ argon-config
--------------------------
Argon Configuration Tool
Version 2203003
--------------------------

Choose Option:
  1. Configure Fan
  2. Configure IR
  3. Configure RTC and/or Schedule <=====
  4. Configure OLED
  5. Configure Units
  6. Uninstall

  0. Exit
Enter Number (0-6):3
----------------------------
Argon RTC Configuration Tool
----------------------------
RTC Time: 2022-04-29 15:14:22
Choose from the list:
  1. Update RTC Time  <=====
  2. Configure Startup/Shutdown Schedules

  0. Exit
Enter Number (0-2):

Thanks. :slight_smile:

I did that. It synchronizes the RTC with the system clock.
htop showed me that the system clock is not correctly set.

It turns out the system is trying to sync with Debian’s time servers, and those are, as of last night, unresponsive.

I changed it to use the NIST servers, rebooted–and the PSU died.

So, I’ll have to check again once i have a replacement.

Update!

I got a new power supply in from Amazon today. I went with this one (not affiliate link): https://www.amazon.com/gp/product/B09BQBWKKT/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&th=1 It had the right specs and a large number of high reviews.

It worked. And, even though the power draw is the same at idle (~25 watts), CPU temp is considerably lower.

  1. CPU: 36 C (Was in the low 40s C range before)
  2. HDD: 33 C to 35 C (Min/Max).

I hear the fan adjusting itself, as well.

Fan Volume: It doesn’t sound like an aircraft trying to take off now. It’s definitely audible in a quiet room, and much louder than my near silent QNAP TS-253D (which also cost $200+ more). But I could live with this if I had to. Still, it will almost certainly end up not on my desk.

In a bit, I’m going to turn on my TV at a normal level and see if I can still hear it. It’s quite possible I won’t be able to. Will report back.

In all honesty, while it’s not TOO loud, especially given the lack of ventilation, it is the second loudest computer I own–and the next loudest one is a rack server with rack server fans. I will most likely end up moving this into my closet if I keep using it. OR try running it with the sides off. The removable side panels really would have benefitted from some vents.

RTC: Raspbian properly changed the NTP time server to NIST’s main rotating address, like I told it to. I’m monitoring the service now, and it hasn’t synchronized yet. It’s supposed to do that every 8.5 minutes. Once the NTP server synchronizes the time, then I should be able to update the RTC. (Again, this is more me making sure the hardware works than actually needing this feature).

EDIT: After about an hour, the CPU stabilized around 45 C. The time still isn’t syncing, though. That’s got to be some sort of Raspbian specific issue, and it’s got me held up. I don’t want to set up a NAS on a device that doesn’t know what time it is. I could manually set the time, but I shouldn’t have to do that.

Hi

I am also having similar issues with my EON I managed to get around the RTC issues but setting the date and time manually then updating the RTC with argon-config but for some strange reason no matter what setting I select for the Fan config CPU or HD it seems to run almost flat out with a slight audible change in tone every now and then.
If I install the utils the fan stops and if I leave it powered down so that it is cold then power up the fan seems to control sensibly but then after a short while it ramps up and stay at almost full all the time.
image

and current config
image

but fan is running almost flat out?

I have posted a technical question to Argon40 directly but still waiting for a reply

The fan is being turned on because of your HDD’s. Modify their temps.

The wobble in sound is from the fact that the argon40 script sets the speed every minute or so… even if the speed is the same as the last iteration. The sound change is 100% for 1 second, then the speed (probably 25%) for the rest of the minute or so.

That still doesn’t make sense as the max temperature of the HD is 42 and the first temp is 55 so anything below 55 should be off? and anyway if you look at the screen shot unless I’m misunderstanding something its set fro CPU? that should also produce that same reaction?

Cheers

@jlspiers

Yes, you are missing the fact that there are TWO files, with different defaults:

argononed.conf
55=30
60=55
65=100

argononed-hdd.conf
35=30
40=45
45=100

So… clearly your HDD temp of 42 is making the fan run at 30%

@NHHiker

Ok that makes a bit more sense the argon-config script didn’t seem to do anything to these files when I ran it, unless I was misunderstanding what the script does. with this in mind how do you change the file its using or does it monitor both files to run the fan?

Cheers

@jlspiers

The fan speed is set by the first thing that crosses the threshold, using defaults:

If the CPU temp gets to 55 degrees C, the fan turns on to 30%. If the HDD gets to 35 degrees C, the fan turns on to 30%.

If the CPU is at 55 and the max temp of the HDD’s is 45, the fan will run at 100%.

To modify the temperature ranges you can us argon-config;

run argon-config
Select 1 for fan config
Then
Select 1 for CPU temp config
or
Select 2 for HDD temp config

OR

You can load /etc/argononed-hdd.conf in your favorite editor and change the values. Don’t use 0 as a value for a specific temp, just comment out the line (#) or simply delete it.

What would you suggest modifying the temperatures to in both cases?
Should they match?

This has been driving me insane! I’ve had to shut the spare room door to hide the noise.

Well, if you do not care about the life of your drives, simply delete everything from both config files and add:

100=100

That way when the temp of the CPU hits 100C, or the temp of the drive hits 100C, the fan will come on. Use this as an indicator that the drives and CPU are dead

OR

You could argononed-hdd.conf to:

45=25
50=75
55=100

Not knowing what the ambient temperature is in the spare room, and not knowing the types of drives… you either have to live with the noise, or live with drives with shorter life spans.

Two Seagate Barracuda 2TB drives RAID 1
No idea of room Temp but I would bet money its around 18C

I’ve done
hdd.conf
30C (0-100 only):20
35C (0-100 only):30
40C (0-100 only):50
45C (0-100 only):60
50C (0-100 only):80
55C (0-100 only):100

CPU
55C (0-100 only):30
60C (0-100 only):55
65C (0-100 only):100

I’ve also put some M2 heatsinks on the drives and one (Pi Heatsink) on the Pi 4 :rofl:

Thanks for your reply

So your fan is running at 50%

I think I need to play a bit more. Even with those settings, the fan was on permanently. The hard drives were at 43C which is crazy given there was no activity. I’ll check tonight on the CPU temp. I’m wondering if I dare risk setting 30C, 35C and 40C @ 0 so the fan only kicks in at above 45C. At the end of the day, I’m saddened at how warm the EON is especially as I’m only using 2 x 2.5" drives so there’s loads of space in there.

Oh, and the heatsinks that I stuck to the HDD cases appear to have made no difference either. :disappointed:

Cheers

Settling temperature values to 0, i.e. 30=0 will (using the Argon code) set the fan to 25%.

If you want the minimum temp to be 45, remove all other ranges and set it.

i.e.
45=10
50=25
55=75