Eon will not boot to SD

Hello all- I was unable to find topic via search, so apologies if this is out there, please point me to thread if it already exists.

I have recently purchased an EON nas, and I having issue booting to a flashed SD card.

  1. The SD card was flashed using PiOS Lite via instructions. I used the Raspberry Pi loader on my Mac.
  2. The SD card is a 64GB Samsung EVO
  3. I’m using a Raspberry Pi 4 B, 8GB in the case
  4. I have 4 Micron 4TB 5100 SATA SSDs in the case
  5. The SD card was previously used in an older Pi and is recognised and can be read from/written to on the Mac
  6. The case is connected to a 4k display via the HDMI socket on the case
  7. I’m using a cheap KB/Trackpad combo attached to the case via a dedicated USB dongle on a USB port on the EVO - this has been verified to work on my Mac and it was in use on the older Pi
  8. I’ve put the SD card in both the SD card slot on the case and, after disconnecting the extension ribbon cable, directly into the onboard SD slot on the Pi

If I try and boot the Pi with no SD card it boots to the Pi splash screen saying it’s attempting to boot from SD. If I then pop in the SD, nothing happens. It also does not seem to recognise that I have pushed the ESC key on the keyboard to enter config mode.

If I put the SD card prior to powering on, the monitor stays completely blank.

I don’t have an alternative SD card to hand or another KB that is not Bluetooth.

Any thought or suggestions to try?


I would try with a different OS image. Also check the sd card for errors. It might just be a problem with the sd card if you are lucky. Also I would try to setup ssh and connect to the pi over the network to rule out a display issue.

Thanks- will try a different image. Don’t THINK it’s a monitor issue as it works fine when no SD card is inserted.

1 Like

Ok crossing fingers! I once had problems with a corrupted image, loading and flashing it new helped.

Tried a few more images- same result. I hate to disassemble the thing, but might be an issue with the Pi itself.

Will take it all apart and try it.