EON RTC Working?

I’ve installed the RTC battery and run the configuration script to set the time on the RTC. I don’t think it’s working correctly as I’ve run the following checks…

Running sudo hwclock -r --verbose I get the following output…

hwclock from util-linux 2.36.1
System Time: 1660171681.701987
Trying to open: /dev/rtc0
Trying to open: /dev/rtc
Trying to open: /dev/misc/rtc
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.

Running timedatectl, I get the following output…

               Local time: Wed 2022-08-10 18:49:44 EDT
           Universal time: Wed 2022-08-10 22:49:44 UTC
                 RTC time: n/a
                Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

Note that RTC time shows “n/a” for a status.

I’ve found various steps on numerous sites that say to disable the fake-hwclock, adding a line to /boot/config.txt to enable to RTC’s hardware, editing /lib/udev/hwclock-set to comment out various lines, etc. I also found a few postings here with steps to follow but after doing all of these things, I still end up with the two statuses above.

Does anyone know the definitive steps to both set up and verify that the EON’s RTC is correctly configured and actually working? I’d really appreciate some guidance with this.

Thanks.

I got similar results to you when I ran the hwclock command.

When I run the argon RTC config script, it gives me this:

pi@ArgonEON:/etc/argon $ . argoneon-rtcconfig.sh

Argon RTC Configuration Tool

RTC Time: 2022-08-11 16:34:39
Choose from the list:

A bit of digging in the argoneond.py script sees they use a function called getRTCdatetime() to get the RTC Time.

1 Like

OK, this helped. I looked in the /etc/argoneond.py script and found this on line 33…

# PCF8563 number system Binary Coded Decimal (BCD)

I recognized PCF8563 as an RTC chipset from previous research. I added the following to /boot/config.txt

dtoverlay=i2c-rtc,pcf8563

After rebooting, dmesg | grep rtc shows the following…

[    8.433407] rtc-pcf8563 1-0051: registered as rtc0
[    8.434654] rtc-pcf8563 1-0051: setting system clock to 2022-08-11T23:46:16 UTC (1660261576)

sudo hwclock -r returns the date and time…

2022-08-11 19:47:27.485806-04:00

timedatectl now shows an actual time for RTC time instead of n/a…

               Local time: Thu 2022-08-11 19:47:35 EDT
           Universal time: Thu 2022-08-11 23:47:35 UTC
                 RTC time: Thu 2022-08-11 23:47:36
                Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

So thanks @BlackRose67…you gave me the nudge I needed!

2 Likes