Eon not connecting to network after Open Media Vault (OMV) install

Hi all, just a disclaimer: I’m an absolute beginner and have very little sysadmin skills so I would appreciate very clear/specific/overly verbose responses if possible!

I just got my Eon and set it up.


  • Pi 4, 4GB
  • 2x Crucial 1TB SSD (2.5in MX500)
  • SanDisk Ultra microSDXC UHS-I Card 128GB

I have the full logs uploaded to this pastebin if you’d like to read through it but I will also try to explain what I’ve done so far.

  • Assembled all of the hardware following the included guide in the packaging (along with some youtuber videos)
  • I flashed the 64bit Pi OS image onto my micro SD card.
  • Booted the Pi up and was able to SSH to it once I figured out the IP address of the device.
  • I ran the script recommended in the included Eon guide to install the argon-config utility
  • Then I tried to run the Open Media Vault (OMV) installation script, but it was giving me errors saying that the certificate to Github was not trusted and expired.
    • I searched for this online and found recommendations on StackOverflow to install ca-certificates (was already installed) and ssl-cert. Neither of those packages made any difference.
    • Then I noticed a comment on that SO post that mentioned checking if the system clock was correct. Which seemed to be the issue, my clock was set to some time in the year 2038. So I tried fixing it by running a couple commands I again found on SO, but that gave me issues with the timezone so I ended up just using the raspi-config utility to update my timezone - which fixed my clock and allowed me to run the OMV installation script finally.
    • Sidenote, I don’t have a battery for my RTC (not sure how that works but I’ll buy a battery and figure it out at some point)
  • At this point since I was able to run the OMV installation script, I started it and walked away to get some chores done.
  • When I came back, it looked like the installation was complete and the script restarted the Pi (which closed the ssh connection).
  • However, now when I turn the Eon back on, I don’t see it on the network (both in my ISP’s router web UI or in my PiHole)
    • Side note, my PiHole (running on a separate Pi and hardwired to my modem) is my DHCP server, I have DHCP disabled on my ISP’s modem/router. I had asked my PiHole to reserve the IP address for my Eon but after not being able to connect to the Eon I removed the reservation to see if that was the issue.
  • I can no longer SSH to it or open the OMV web UI at the device’s URL.
  • I tried pinging the device IP address but get the “Destination Host Unreachable” message
  • I tried restarting the Eon multiple times (both with long pressing the button and also by removing the power cable)
    • The device definitely turns on (I see the lights on the Pi light up and also the fan spins up)
  • The OLED tells me the RAM/CPU/Storage utilization percentages so it looks like the Eon can talk to the Pi but not the Pi can’t connect to the network somehow.
  • I should also note that I’ve tried the following configurations:
    • Reserve IP in PiHole DHCP settings
    • Unreserve IP in PiHole DHCP settings
    • USB-SATA bridge plugged in
    • USB-SATA bridge unplugged
    • Restarted from long press on power button
    • Restarted from unplugging power cable
    • Attempted SSH with pinas.local (pinas is the hostname I used during RPi imager configuration)
    • Attempted SSH with pinas.lan
    • Attempted SSH with the original IP address it had obtained (

I have no clue what’s going on or even how to troubleshoot at this point.

I would really appreciate any help at all!

Thank you!

Responding here since I can’t update my original post anymore for some reason.

I figured out the issue was that the Pi wasn’t connecting to the network anymore. I had it initially set up with Wifi and had saved the SSID/password through the Pi OS Imager configuration. I ended up having to connect to the Pi physically (with a monitor and keyboard) and running the sudo omv-firstaid utility to connect to the network.

Hope this helps someone else in the future.