EON Failed to Power On After Initial Setup


I am backer 789. I received my unit on 01/27/2022, and was able to assemble it with a RPI 4 2GB and 2 3.5 SATA HDs. I installed Raspberry Pi OS Lite (Bullseye), the Argon EON firmware, and OMV 6. I was able to use OMV’s web interface to begin the disk and file service configuration. Unfortunately only one of the two disks was being shown in the configuration menu, so I requested a shutdown in OMV’s web interface. The unit remained powered on, so I tried powering it off with the power switch, but it would not power off. So I disconnected the PSU from the unit. I ensured that the disks were properly seated and secured to the back of the unit. I reconnected the PSU to the unit and tried to power on the unit with the switch and the unit would not power on.

I disassembled the unit and tested the RPI with an USB C PSU and the board was able to boot. I tested the Argon forty PSU with a voltage tester and it was providing 12.1 v.

I did notice that there was an odor that I assumed was associated with normal circuit board “burn in”. I did not notice if the fan was functioning or if the OLED was functioning as expected.

Any assistance would be appreciated.

Update with Additional Information

I used a 12v 5a PSU and tested using the EON power jack and the RPI showed no power, I think plugged the PSU into the RPI using the onboard power connector jack and the RPI powered on.

The pi stays powered on if you don’t have the Argon script installed.

Once the script is installed, it does power down.