Curl Script error for Ubuntu 21.10

Hey there!
I tried using the curl script on Ubuntu 21.10 and it didn’t work. it was looking for raspi-gpio which I don’t believe Ubuntu 21.10 has.
Any ideas for a work around?

@jet438 I just tested and am seeing the same ( script installation (E: Unable to locate package raspi-gpio) error that you mentioned.
It looks like raspi-gpio has recently been replaced with python3-lgpio (as of Linux Kernel 5.11) but I’m not certain if this updated package can simply be replaced (while retaining the script functionality).

I would recommend checking in with the Argon support team ( to ensure that they are aware of the need for an updated version of the script.

Thanks for the reply and the validation. I wrote to Hopefully they’ll be able to massage the script quickly.

1 Like

Please update the thread once you have a response. I’m having the same issue here.

Will do.
Only upside to this issue is it probably keeps cooler since the fan keeps running. :slight_smile:

Same on my newly installed ubuntu 20.04.
Thanks to the tip I’ve changed the script to install the python3-lgpio instead.
Got the LED screen working now, but the fan control is not working for some reason, fan is at full speed.

If you’ve installed the latest version of the scripts, there’s an issue with the HDD temperature configuration disagreeing with the overall system temperature configuration.

See this post for more info.

We are currently looking into it and we’ll post here when we have updated the install script. Thank you.

Just a heads up, the script also does not work in Ubuntu 22.04 Beta.

Is there any update in the script for Ubuntu?

Hi the script have been updated and should work in ubuntu.

1 Like

Still not working in my case, in a fresh install of Ubuntu 22.04 beta. The installation ends with this error message:

E: Package ‘hddtemp’ has no installation candidate

Please also connect device to the internet and restart installation.

Any ideas?

I have an idea. Maybe Argon could host the development of the script on github so we could help fix it ourselves.

Well some findings.

The script works well on Ubuntu 21.10 server, and Raspberry Pi OS lite.
It doesn’t work on Ubuntu 22.04 beta because still there are no candidate package for HDDTemp.
So I have to wait for the final relerase to see.

One thing I’ve observed is that, just after Argon Eon installation, it appears 1 zombie process in both OS’s.

The initial script had the same issue with the zombie so it’s not by virtue of any recent changes.

I tried the script. It installed and didn’t produce a zombie. That’s the upside. On the downside, the script, once running, did/does absolutely nothing. No fan control. No LED panel. Zip.
I ran the uninstall script and it indicated, by the errors, that there are/were several files that weren’t removable because they didn’t/don’t exist.
So right now I’ve got bubkus.
Any help is greatly appreciated. Using ubuntu 21.10 btw.

Hi jet438. I’ve installed today the script in a new fresh Ubuntu 21.10 server install, and it works fine for me. No more zombie process, and at least OLED panel, RTC and fan control are working fine.

All I can say is: What the heck?