Command line interface hangs sporadically

Hi all,
I’ve got a rather fresh install of Raspberry Pi OS 64bit in an EON, with NHHiker’s control scripts in place (unit files modified as per my post). The scripts run nicely, thanks @NHHiker for providing!
One remaining fly in the ointment however - the CLI hangs every now and then for a few seconds, without any obvious reason or consequences. Has anybody seen this before (or ideas how to debug this)?

Depends… which CLI? argon-status?

If so which command exactly. The script has to perform a number of commands, so it maybe that the commands are executing in the background and when everything is finally obtained, the data is shown.

Some commands take much longer to sort out…

Yep, should have been more precise… I meant the bash shell in general. The ‘hangs’ seem not to be related to a foreground command being executed, but due to some background activity. This may or may not have sth. to do with the argon scripts.
One obvious 1st debugging step would be to disable the services one by one, and see if the problem persists. However, there are times when no hangs occur for an hour or so, so it’s not a quick check (and more importantly, my system is down at the moment).
Maybe there is a way to log such times of unresponsiveness? I’m not sure though what could actually cause a multitasking OS such as Linux to become unresponsive for some seconds?

I’m not seeing anything that slows down or pauses the shell, so not really going to be able to debug this for you.

  1. Run htop and see if there is a correlation between when you see a “pause/no-responsiveness”, and a particular executable.
  2. What else is installed on the system?
  3. Are you using the realtime clock? i.e. is argoneond.service started, and if so are you utilizing it in any way? I don’t.

Meanwhile this is solved - finally I took a look at dhcpcd logs, and could see quite some ‘carrier loss’ messages. I found these to be caused by a defective switch port.
Thanks for your suggestions anyway…
By the way - is it possible to edit the title of the thread (to include [solved])?