Cannot make the hdd writeable

Newbie here. I had a pi set up as a local video server using an old WD mybook as the storage and using samba share to connect to VLC apps on the TVs. I just upgraded to the EON case and a new WD Blue 8TB hdd.

For expediency, and here’s probably where the trouble starts, I temporarily installed the new hdd in a windows 10 pc, formatted it ntfs, and copied the relevant folders. (It’s the same way the mybook was formatted, and it worked fine.) It’s about 1.5TB of data, it’s not practical to transfer it over the wlan.

Anyway, I moved the hdd into the EON and it started up no problem, VLC can read and play anything on it. But it’s missing 2 crucial functions currently.

  1. I cannot connect to it from the windows pc. EON has a static IP address, but I must be typing it in wrong when I go into “add network location” or “map network drive” to add it. It may also be that I didn’t create a “shared” folder on the hdd, it has a folder for movies and a folder for tv shows and I tried to make the whole drive shareable. I could probably fix this except for problem #2.

  2. the hdd is read only. I’ve checked that I have ntfs 3g, In fact, from the file explorer the “create new folder” button is greyed out even for adding folders to the sd card.

Any advice is appreciated. Thanks!