Cannot install OMV per instructions on latest Raspberry Pi OS Lite

Hi all.

I’m having a very frustrating time trying to get my Argon Eon NAS up and running. I am following the instructions included in the little booklet that came with the Argon Eon tower, with the exception of the Raspberry Pi OS Lite version:

SHA256: bf982e56b0374712d93e185780d121e3f5c3d5e33052a95f72f9aed468d58fa7
Raspberry Pi Imager v1.7.5

Downloaded straight from the official website. The instructions point to the 32-bit OS, but I’m using the 64-bit OS (which, as I’ll explain shortly, won’t matter). I’m running the commands as follows:

sudo apt update
sudo apt upgrade
wget -O - | sudo bash

Exactly as in the instructions as well. However, I keep running into the following error:


Failed to preset unit: Unit file sshd.service does not exist.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on sshd.service: No such file or directory
dpkg: error processing package openmediavault (--configure):
 installed openmediavault package post-installation script subprocess returned error exit status 1
failed to install openmediavault package.

I’ve spent hours trying to troubleshoot this problem. I’ve tried using the 32-bit version of RPOS Lite, and that still didn’t work either. I tried Googling for help, and this post was the only relevant result I could find, but it’s still not related.

The only solution I found was to downgrade from the Bullseye version of RPOS Lite to the Buster version from August 2020. The 64-bit version of that will succeed, so again, I don’t think the problem has anything to do with the OS being 64-bit.

Can anyone shed some light as to what’s going wrong here? I would prefer to not stay on an outdated/unsupported OS version just to use the Eon.

I don’t use OMV, but with an older version of RPOS working and the “latest” not working, I would suspect something with the OMV install…

Possibly check OMV install errors.,…

I’m running the 64-bit lite version of Raspberry Pi OS (bullseye) with the latest version of OMV.

I did my install of bullseye back in January 2022, and I keep it up to date with patching, so what I’m running now should match the image you downloaded.

In /etc/systemd/system my entry for sshd.service is a symlink as shown below.

sshd.service → /lib/systemd/system/ssh.service

1 Like

Hi. Thanks. I was finally able to get OpenMediaVault set up by creating the symbolic link using:

sudo ln -s /lib/systemd/system/ssh.service /etc/systemd/system/sshd.service

I wish I knew why this wasn’t done in the latest RPOS images, but I think Argon40 needs to make an updated guide for how to set up the Eon. I was VERY close to returning the product this coming weekend due to how nightmarish this troubleshooting process has been. :frowning:

1 Like

I had the EXACT same problem! Today! Trying to install OMV on my Raspberry Pi 4B. Followed exact same procedure, used exact same software versions, and got the exact same error messages. I had previously installed OMV on this Pi with no such problems, but would have been under slightly older versions of RPi OS (Lite) and OMV. (I think SD card got corrupted so needed to redo.)
It made no sense and I was stumped until I found the posting here. I tried the solution and it worked! (Entered the command after update/upgrade and before OMV install.) So … something is amiss here. It’s not us … it’s them. Thanks!

OMV 6.x is only built for Debian Bullseye compatibility, version 7 for Bookworm is not released yet. (Source: OMV forums)