Cannot get fan or OLED to Work

I’m running dietpi 64bit - booting off an m.2. drive via a USB adaptor. I’ve done everything I can think of, made sure i2C is enabled, installed python and I’ve tried both both the standard argon script and NHHIKER’s custom script and nothing seems to get it going.

The OLED DOES flash the “Argon EON” logo and the fan runs briefly at power on. But that’s it.

Any potential help would be appreciated.

Are you using the stock argon software for the system, or did you download my modified versions?

So I went and installed Raspberry Pi OS Lite 64-bit instead and then installed your script.
The same issue, the OLED now works but the fan doesn’t at all. I tried setting it to “always on” but it never fires up.
It DOES spin up on a bootup so it is getting power etc.

Well, what are the settings? /etc/argononed.conf, and /etc/argononed-hdd.conf

This controls the fan speed. The fact that the fan turns on at boot indicates to me that stuff Is working


sudo argon-status

As well

I set both to always on for testing purposes so:

Argon Fan Speed Configuration CPU

Min Temp=Fan Speed


Argon Fan Speed Configuration HDD

Min Temp=Fan Speed


But sudo argon-status shows;

Fan Speed

Speed %


Uninstall and pull the absolute latest… There was an issue. Might be what you are seeing.

After doing this please post all of the output of sudo argon-status

CPU Utilisation:

cpu0 0
cpu1 0
cpu2 0
cpu3 0

Fan Speed

Speed %


Storage Usage:

Device Total Used Pct
sdc 917GB 2GB 21%


Total Free
4GB 96%

CPU Temp:

°C °F
53.1 127.52

HDD Temp:

Device °C °F
sda 33 91.4
sdb 31 87.8
sdc 48 118.4

IP Addresses:

Interface IP

Disk Utilisation:

Device Read/Sec Write/Sec
sdc 3KB 8MB

That’s the full output - same issue. I also confirmed everything else is fully updated and i2c is enabled.

You may want uninstall, then reinstall with the absolute latest as mentioned in my other post, As you can enable debugging and we can see a log of what is happening…

I would uninstall, reboot and install the new code.