ArgonPOD Display 2.8 inch not working on Raspbian Lite and DietPi

Hi everyone,

I am developing a product using RPi Zero W’s for an embedded application. Because of this I’m using high performance / GUI-less operating systems such as Raspbian Lite and DietPi.

This 2.8 inch screen would be PERFECT for on-site debugging and just development in general, but I cannot get the driver to install properly. I was wondering if anyone has experience this and might be able to help. I’ve tried to install it on both Raspbian Lite and DietPi, but get the same following sequence of errors:

  1. I input the curl command to install the driver, as per the booklet that shipped with the box: curl https://download.argon40.com/podsystem.sh | bash
  2. I get a bash copy error (cp) during the installation, plus a ‘unexpected file end error’
  3. I try to enter argonpod-config but it says command not found (screenshot attached)
  4. Then, the worst bit, after this failed installation, the HDMI port gets disabled/no longer works, and I have NO idea how to uninstall it because again, the argonpod command is not found.

For the sake of this screenshot, I tried running the curl command again, and got an output saying ‘Update completed’, but nope, argonpod-config is still not recognized. Sigh…

Any ideas? Is this driver only made to work with a full raspbian distribution or am I missing something?

Edit: I re-attempted the installation with a full raspi distro and finally, the driver installation worked, and the screen is now displaying properly

Definitely not an ideal situation though.

Does anyone know if there’ll be any support for non-raspi or non-GUI OSs?
Maybe I’m only missing a couple of libraries associated with the full distro installation, and can download them separately?

hahaha, well this thread is turning into me talking to myself, but eh, whatever, I’ll still post the results in case it helps anyone

It turns out that despite the failed driver installation, and inability to execute the argonpod-X commands, the screen actually does still work. Photo attached.

Whatever. This is fine for my use case :man_shrugging:

1 Like

I’m trying to get it to work with Volumio, to display coverart, not getting any information here, got one person on the Volumio forum to help out, but still not working, is what you did similar, or have you tried it with Volumio?

Thanks.

As you discovered, the screen still works just fine after a reboot, but the argonpod-config command doesn’t work. I wanted to be able to turn the screen off, so I went poking around and found this resource: https://www.redhat.com/sysadmin/fix-command-not-found-error-linux

It would seem the file isn’t copied into the home directory, or something like that (I am admittedly a little new to programming). Anyway, when I entered /etc/argonpod/argonpod-config the script ran with no problem, allowing me to program the buttons.

Not sure how to re-enable the HDMI port, or if it’s even possible, unfortunately.

Hope this helps!

1 Like

@Scuzzbucket @Mel sorry for the late reply, I missed the emials from this forum.

I’m not aware of Volumio or have any experience with it sorry, so I can’t really comment.

@Mel awesome to see that you got it to work. Yes that link definitely helps! the PATH variable… of course! thanks, I’ll give this a shot when I get home today.

1 Like

Yeah so just going into etc/argonpod/ and running the command still does not work.
You need to run the command with its full location. ‘/etc/argonpod/argonpod-config’
then it will run.

I was confused for a bit until I entered the path and command.

Even after that, the changes do not work. I did it through SSH then again locally and no go.
The changes appear but the buttons do nothing.

Did you restart after making the changes?

Yep several times. Now tried it on a piOS lite install and still same problem with not finding the command.
Full path and command works. But now after a reboot the pi and display get stuck on boot in the ey daemon and g Services.

Cannot even SSH into the pi.

Oof I’m sorry. I’m not sure what’s going on at this point. For me the trick was just to type in the full path like you said, then I was able to change settings, then restart and it worked.

1 Like

All good I may try it again later. What Image of dietpi did u use??

I am going to try the 32bit version of piOS Lite see it that helps.

Else ill try find the Github of Screen see if I can find something there.

–Edit–
Ah ffs, yeah that’s an old f-ing script that no one has bothered to up date… You best go to
GitHub - goodtft/LCD-show: 2.4" 2.8"3.2" 3.5" 5.0" 7.0" TFT LCD driver for the Raspberry PI 3B+/A/A+/B/B+/PI2/ PI3/ZERO/ZERO W and follow the instructions for your OS and Screen size.
Its still a 1year old repo but hopefully that will work. Have not tried it yet.

–Edit2–
Yeah no go on the repo. Buttons still don’t work and now after installing the screen resize it has caused the screen to just sit on the last screen boot script screen. I can login without being able to see what I am doing and SSH but screen is useless.

–Edit3–
Ok after reviewing the script and doing an install under piOS Full. It seems like the script is not Terminal only / lite friendly. As everything appears to work in desktop.
May be able to get i to work under a minimal / lite install but you would need to configure everything by hand. Or I am just a total Snow who knows nothing.

So I’m a little late to the party, but I installed the driver on my raspbian lite distro ahead of actually getting my display and ran into the same errors.

Oddly enough, I might’ve stumbled onto a weird fix. After some frustration not getting the argon commands to work, I tried to uninstall using the uninstall script. That didn’t work, so I modified the script to take out user input and ran it. Then I reinstalled and I now have access to the argon commands. I just programmed the buttons, and that ran fine.

Will update when the display arrives in a couple days with my results, though I’m not overly optimistic… And no, I have no idea why it worked.

UPDATE: Display came in, connected it and everything worked. For specifics, I’m using raspbian os lite 64-bit bullseye and ssh’ing into the pi.

For a step-by-step, here’s what I did below. Probably some unnecessary steps, but it works so…

 curl https://download.argon40.com/podsystem.sh | bash

 sudo reboot

 *ssh back in*

 sudo apt-get update

 curl https://download.argon40.com/podsystem.sh | bash

 sudo nano /etc/argonpod/uninstall.sh
 #remove lines 2-23 and save

 sudo sh /etc/argonpod/uninstall.sh

 sudo reboot

 *ssh back in*

 curl https://download.argon40.com/podsystem.sh | bash

You should now have access to the argon commands and the scripts should work. Hope this helps everyone!

WARNING: Do not try to install FBCP Driver on RasLite - FBCP is intended for full GUIs and will cause a failure to boot properly on lite distros. Silver lining, me making this mistake forced me to repeat the steps from my accidental fix the other night which let me provide them here in better detail.

1 Like

Can also confirm the install script works without issues on raspbian lite bookworm