Argonone fan speed when using always on pin setup

Hi all,

I have an issue while using the JUMPER PIN SETTING set to pins 2-3 ( always on). When I use this setting the fan is running always at 100% speed. Tried to reconfigure the fan but without luck.

When I switch back to pins 1-2 it is working just fine. Is this a bug or is this intended behavior? And also how I can change it?