Argon v3 power supply requires 5A

My pi 5 (8gig) has been working great since I got it with the genuine pi5 5A power plug but now it is installed inside the v3 case every boot fails telling me I need a 5A power supply… what gives

The only way to get the system to boot is to add the usb_max_current_enable=1 line to my config.txt

Is the power/hdmi board loosing power somewhere or restricting power to the pi. I do not have the m2 or any other items connected.

1x genuine 5A psu
1x 1tb sata/usb hdd (boot device)
1x hdmi cable
1x usb wireless mouse/keypad

Everything works without problems out if the argon v3 case (no warning about power).

When in the case the power problem shows every time until the config.txt is edited

If I remove the boot usb hdd and boot from msd I still get the error so it`s not related to booting from the usb hdd and has to be the argon v3 case.

I know its CNY but since these cases have just started to ship I can not be the only one with this problem


I’m having the same issue. It boots fine from SD card, but ANY usb device is a no-go.
Tried loading the argon V3 file but line 18 showed an error and full usb power not loaded in the config.txt file. Working with Argon support now. Will update.
Looks like user error. I had the MAX_USB_CURRENT setting BEFORE the [ALL] in the config.txt file.
ALL is good. Everything works.

1 Like

Same issue here. IMHO the case/board should allow for proper USB power detection and not require the config.txt entry. I’m disappointed.

I’m using the official Raspberry PI power adapter sold for the 5 and experiencing the same issue. Yes, it works after the edit, but why is this even needed?

It is needed because of how PD polling signal is designed. the polling signal only last a few seconds. Since Argon One need to control the power on and off, it is simpler to bypass it thru the eeprom configuration. The current design would still deliver the same exact current rated by the power supply. It is a simpler solution than still adding another circuit to do the PD communication which would add further to the cost. Technically, the current design still allow for the PD detection, which is the reason why the power supply is able to supply the 5V, only thing missing is the reply signal from the power supply as the polling time already lapse when the power button is pressed.

It doesn’t sound good to me, you want to modify eeprom configuration and break the USB-C standard. A better solution would be to utilized the PI5 onboard fan and power button so you could use general control and there by making the circuit simpler and cut cost.

Correct me if I’m wrong but I don’t see any benefit having the fan and power button running on separate circuit from the PI5?
Personally i chose ONE instead of NEO because of the full-sized HDMI.

Thanks for the explanation.

You are not wrong, but there are some use case would need complete power cut off for Raspberry Pi than just the current standby mode. Modifying the eeprom config does not affect the way Raspberry Pi is being powered or how it functions. As for the fan, there is merit for a controllable fan and not having to connect and disconnect the fan everytime Pi is remove from the case. We found the current connector easy to break and once broken, there is no way to make the fan work.

We are actually also coming up with a V5 version in a different form factor that would make use of the on board power switch and fan, it comes with full hdmi and also on board audio and mic.


Argon One have been our most popular product so far. The Raspberry Pi community have adapted the product and have deployed it in different use case. It is beyond what we planned for the product. There are many opensource project developed by the community for this case. So when we design the V3, we keep in mind to keep the functions(part of this, the power and fan control) to be backward compatible so that it would still work with any of the existing use case for Argon One.

1 Like

are you also going to update the libreelec addon to bring it up to python 3 and use the new gpiozero since rpi.gpio seems to have fallen away due to newer aarch64 platform codebase so we can actually use the fan and power buttons as how they were designed to be used ?

Yes, we are updating all our current scripts.


any time frame as to when they will be done ?? days ?? weeks ??

I just bought the Pi 5 One v3 case.
Does this mean none of the scripts work and we bought a not fully functional case that needs to wait for script update?

The installation scripts that we officially support are updated and should be working.

Same issue here, official 27W (5.1V at 5A) power supply, soon as I plug in the daughterboard and the top it complains about not enough power to boot from USB, if I override that it complains when I get to the desktop. Everything works and boots fine until I put it in the new case, tried reseating it etc… something is not right or something is drawing a load of power!

Doesn’t sound good to me either…It should have had such a circuit, as it is it’s a case that needs a workaround to work and I don’t trust it. Once built you can’t even access the Pi’s power button to bypass the check if things aren’t set up, the SD card slot is blocked by the use of a straight PCIE cable instead of a dogleg. it’s just not what I came to expect after my experience with the Pi4 ONE case and the Pi5 NEO case that I fear I’m now going to have to go back to and wait for the NVME base… the Neo case is really nice, even if we are stuck with micro HDMI.

Raspberry Pi 5 just limit the power provided to the USB when polling response from PD is not received. please follow the setup process as mention on the manual and it should resolve the issues.

Yes I see now that if you use the argon scripts for the power button the manual does say it puts the usb_max_current=1 into the config.txt I’d just done that anyway and yep, it works fine and isn’t complaining about things anymore.
Only thing I’d say would be to make this (the fact that it will complain about USB boot without the settings) a little more clear in the paper manual as lots of folk are likely to boot it up, probably from a previous USB SSD as the SD card reader gets tucked away inside the case to check things are working before installing an NVMe drive.

Anyway, thank you for getting back to me and I think I’m happy now! :slight_smile:

And yes, feel free to shout RTFM . :slight_smile:

The libreelec scripts has not been updated in 4 years however

1 Like