Argon V3 only getting 3 amps until reboot

I have taken apart and checked the daughter board twice now. Making sure there was a slight click and that it is firmly connected. When I power on the PI 5 inside the Argon One V3 case Pi OS gives the insufficient power message. It seems the Official power supply is putting out 3 amps. If I hit reboot then it puts out 5 amps. I don’t understand why the reboot is required. Outside the Argon One case I have no issues at all with power.

This is happening with Pi OS on an SD and LibreElec on an SD. LibreElec has even more issues as it seems the scipts that Argon instructed me to install don’t even work.

I’m using the BLSTR Dac as well so don’t know if this could be causing some of the issues.

As far as I know, the RPi5 tries to negotiate the max current with the power supply via PD (power delivery protocol). The internal pcb of the Argon ONE V3 can’t passthrough this information to the RPi5, because its a sink by it’s self. The IC (RP2040) at the case pcb doesn’t supports/simulate the PD negotiation between the pcb and the RPi5, so it’s needed to force the RPi5 to know that your power supply can deliver 5000mA.
Please ensure, that you have a sufficient power supply (27W). Some peoples seems to have tried to used the “old” one from RPi4, which is not sufficient.

Please check your bootloader config / EEPROM, if there is this entry:


and in your config.txt


For your BLSTR DAC I think you must add this line too:

like described at page 14 of the case manual.

For LibreELEC you shouldn’t use the script. There exists a Addon ( from Argon40, but this is currently a outdated version 0.0.1 (doesn’t supports newer than LE 9). Please give the updated version 0.0.13 a try.

1 Like

Thank you for your help. I do have a real 27 Watt power supply so I made the updates you recommended and that solved the power issues I was having. I have powered down and restarted several times with no errors and have left the Pi running for a couple of hours with no errors or issues.

Thank you for the new LibreELEC script. This got the power button on the remote working correctly and seems to have Kodi working correctly with the V3 case.

I did have that line already for the BLSTR Dac and that has been working fine in Pi OS and the latest version of LibreELEC.

Thank you again for helping me get this case working correctly.

1 Like

Nice to read, that it works now. You are welcome.

1 Like