Argon Setup JeffCurless

got some prob here in install, pop up blue screen but cant pick anything under raspbery

if i take the config manual theres no prob.

is this code

Ubuntu Mate for RPi has raspi-config too

command -v raspi-config &> /dev/null
if [ $? -eq 0 ]
# Enable i2c and serial
sudo raspi-config nonint do_i2c 0
sudo raspi-config nonint do_serial 2

what can i do there?

I have the same under 64-bit Raspberry Pi OS Lite. The shell over serial question doesn’t work, crashes the script. Can we set it up manually?

@AhnFire did you try setting it up manually?
I also ran into this issue.
Seems the power button works for turning on and off for now though.
Did however run into a situation where I shutdown from within Pi OS and the fan kept running for way too long, had to turn it back on and press and hold the power button for it to turn off.

I’m trying to remember where I was with this. You are referring to the setup script, right? I had tried something very funny and it worked. I am not sure why. I’ll list what I did.

  1. Bookworm 64-bit lite - Did not work. Basically crashed on that screen, could not select go or stop.
  2. Bookworm 32-bit (with desktop) - Worked in terminal.
  3. Bookworm 64-bit (with desktop) - Worked in terminal.
  4. Bookworm 64-bit lite - Worked! I have no idea why (did they fix the script?)

That leads me to where I am now. For other compatibility reasons, I am now on Bullseye 64-bit lite (the prior debian/Raspberry Pi version aka Legacy). It works fine there. So now I am sorted.

I hope my nonsensical steps above help you get it installed and configured.

Bookworm on a Raspberry Pi 4 with my scripts???