Argon POD Display Module not working

The screen doesn’t work properly. I have tried with different operating systems (both 32-bit and 64-bit versions) and with two Raspberry Pi Zero 2 W, but I don’t get any video on the screen. The screen just stays blank.

Do you get the flash screen with the raspberry logo before it goes blank, or not even that?

the screen is white all the time.

Sounds like you need to install the driver. Instructions are in the booklet. If you want the full desktop to show up, you will need to install the framebuffer driver too.

I followed the instructions from the manual, downloaded the script, and configured it, but it still doesn’t provide a video signal.

Which Debian based version? 11 Bullseye or 12 Bookwork?

My screen always lit white…what am I missing please?. Thanks.

I’m having the same problem…did you resolve it?. Thanks.

It doesn’t work in either of them.

No, I’m still having the same problem.

Hi, I’ve been writing to support to get a replacement or a refund at least for the display module…expecting a reply…the others appears to be working ok… regards.

I also tested buster…with no luck…

I wonder which current os versions works…my display module still showing white screen even after installing driver and framebuffer driver too…after testing differents os versiones and different oses versions… and even other raspberry pi zero 2 ws…I’m beginning to believe that display module is fault…

It’s working with Bullseye 64bits Full

Thanks. What script do you use for drive setup? the official I think works to bullseye…but got erros in Bookworm. Do you use soldered pins to rip zero 2 w or the ones included with basic module?.

I follow steps in this video :
I soldered hat that comes with argon pod

Thank you very much.

I think I found a fix for this issue. I started with a clean version of Bullseye Lite. The instructions say to enter this command in terminal:

curl | bash

HOWEVER I think something is wrong with the .sh file. So instead I entered:

sudo nano

and all I changed in the file is right here:

CHECKGPIOMODE=“libgpiod” # libgpiod or rpigpio

Try changing it from “libgpiod” to “rpigpio” and save the .sh file and then bash it. With that one change in the .sh file everything installed perfectly, and I had a working screen, full access to argonpod-config, and could set all my buttons. It should look like this:

CHECKGPIOMODE=“rpigpio” # libgpiod or rpigpio

I haven’t tested it on any other versions yet but I have a feeling anyone working with no GUI will have to make this change before running the script.

I’ve managed to install display on bullseye. Driver needs update though.
Unfortunately display is working for me, but not a touchscreen.