Argon one V3 M.2 NVMe PCIE not working

Hi all,
I’m have been working since 4 days (and parts of the nights) to set up my new Argon one V3 M.2 NVME PCIe for the Raspberry Pi 5. without avail. While my shiny new raspberry pi 5 works very well “nude” without any case with the micro HDMI connector and on my wooden desktop, I simply cannot get it working within my the argon one V3 M.2 NVMe PCIe case. There is no HDMI display what so ever even knowing that the Pi5 boots, as I can tell from the green LED on the Pi and as well from the VNC server which shows me the desktop when I connect to it from my other raspberry PI., as I found out after some fruitless trials, works only with X and not with wayland. The life of the Linux user is a very difficult one - rarely new things work on the first shot. I read lots of articles and tried out many suggestions mainly concerning the config.txt files, to no avail. I own also an older Argon case I use with my raspberry Pi4 which works well and tried to port the settings in the config.txt file to the new raspberry Pi5. No success! The worst thing is, that for each try I had to remove th Pi from the case with the risk of breaking it even if now, where I got the VNC server working, this will not be necessary any more. Up to now I have not even arrived at trying out myPCIe SSD card because I’m stuck with the “no HDMI signal” message on the screen. I forgot to mention that I’m using the official 27W USB-C Power supply and that when I start the argon one without the micro sd card inserted I can see the various messages on the screen where obviously the bootloader complains that the SD card was not detected and that nvme could not be opened. I’m very close to giving up and return the case to the shop.

best regards

I am sure that Raspberry Pi website has a list of known M2 NVME SSD’s that work with the Raspberry Pi. Whether Raspberry PI publish it, or not, there is an online guide out there, so search.
Find and check the list of known ‘good’, or known ‘bad’ SSD’s and let us know what SSD you have… and whether it is good/bad/unsure or unknown on the recommended list.
Hope this helps…

I just re-read you post… are you using the case and accessories for a Pi 4B, or the newer case and accessories for the Pi 5… that will probably not end well. Just confirm that all your hardware is for your Pi 5 PCB…

I’m extremely bummed. I had a Argon ONE m.2 for my Pi4 and LOVED it. Thought this would be the same experience. It’s been the complete opposite. It’s not going well. My Pi5 works fine out of the box with microHDMI and usb or sd card boot. It’s fine. My Pi is FINE. Put it in the Argon40 case and the only way I get any display is if I have no USB/sdcard/nvme installed and the boot loader is trying to find an OS.

I ordered Mar 30. It finally arrived Apr 26. Tried everything under the sun to get it to work. Nothing. Back and forth with customer support over 2 weeks and was told they would send a replacement… It’s been crickets ever since.

I ordered a different case NOT argon and should be here 3 June. Delivery time just over a week. Also coming from overseas. If that works. I’m boxing up what I have and it’s going in the trash because I know the refund process with Argon is going to be garbage! I’ll eat the $60 before I spend any more time on this company.

Hi, Fustercluck,
I tried to state my problem clearly, but obviously I expressed myself mistakably. My Problem is with the Argon one V3 M.2 NVME PCIe case for the rpi5. I own also several rpi4 and one Argon one V3 for the rpi4. The latter works, even if the wifi did not work so well - a known problem. I wrote in my post “Up to now I have not even arrived at trying out myPCIe SSD card because I’m stuck with the “no HDMI signal” message on the screen” That is the status even now. I’m trying to set up the thing step by step. Since I have no HDMI display I thought it pointless to proceed with connecting the PCIE extension board yet. I can therefore not tell if my SSD works or not. But I’m quite confident since I purchased one of the the SSD’s recommended by the reseller.
regards karl

Hi Karl,

do you have already tried the Pi5 with another screen, only to ensure that the RPi5 + kernel isn’t more sensitive regarding the EDID data?

An important thing is, that the RPi5 needs more power than the RPi4. The negotiation between the power supply and RPi5 via PD (Power Delivery) doesn’t work inside the Argon ONE case. This is the reason to set the parameter PSU_MAX_CURRENT=5000 in the bootloader EEPROM configuration.

Normally I would expect that you get a boot screen, also without that parameter, but who knows? By the way, which OS/distribution you currently trying to boot?

Please can you check your current settings in the bootloader config and provide the content of your config.txt? This should be possible via SSH/PuTTY without disassembling the case.

bootloader configuration:
sudo vcgencmd bootloader_config

sudo cat /boot/firmware/config.txt

Hi HarryH,
Thank you for posting. Unfortunately I own only two screens (Asus HDMI) of the same type, but I would not be willing to buy just another screen only because the Argon case is not working. Before publishing my first post, I tried out most of the suggestions I found in the net concerning my problem. PSU_MAX_CURRENT was one of those. I also use the original 27W rpi powersupply. I use RVNCconnect to change files from another computer. Unfortunately it took me quite some time to find out, that RealVNC works only with X and not with Wayland. In the meantime I have contacted the customer service and with them tried some other possible solutions. As it seems, they wil replace the HDMI Daughterboard
best regards karl