Argon One M.2 USB 3 issue

I bought the Argon One M.2 to run Home Assistant smoothly with an integrated SSD. To install HA on the SSD, I used a USB extension cable in combination with the supplied USB Adapter. Windows recognized the SSD, and the Raspberry Pi Imager completed the process correctly (no error messages).

Unfortunately, it is impossible to boot my Raspberry Pi 4 with the USB Adapter connected as intended. Since the USB extension cable I had available was of an older model, I came up with the idea of using two extension cables with the USB Adapter in between. It’s a clumsy (temporary) solution, but it works!

I have also tried connecting the M.2 expansion board with a short USB 3 cable (male A to male A) to one of the two USB 3 ports. It only works if I use one of the two USB 2 ports instead.

The problem arises when the M.2 expansion board is connected as intended with the USB 3 adapter (or USB 3 cable) to one of the two USB 3 ports.

The same problem occurs when I try to connect the M.2 expansion board to my computer’s USB 3 port via a USB 3 cable because Windows does not recognize the SSD. If, however, I connect via an older USB cable, Windows recognizes the SSD.

It seems to be a coincidence that it worked in the first place because I only had older USB extension cables available then. It probably wouldn’t have worked if I used a genuine USB 3 cable (as it should).

Right now, I can make it work by connecting the M.2 expansion board to one of the two USB 2 ports via a short A to A cable, but that’s different from how it’s supposed to be!

Has anyone else had the same issue, and is there a solution?