Argon One M.2 not recognizing M.2 SSD

I have a Crucial P3 500GB PCIe Gen3 3D NAND NVMe M.2 SSD that is not being recognized by the Argon One M.2. I have boot from USB as primary but the system cannot find the SSD on boot up so it switches to the SD card - which works fine. If I run Pi Imager the SSD is not listed as a target or source device.

I do find it interesting that the instruction manual actually states " This Board is NOT compatible with M.2 NVMe Storage Drives". What’s going on?

I have tried booting with and without the USB jumper in place - no difference.

Thanks for any help,

try this:

Thanks, I tried runing it and the update program fails to find my SSD

Nothing shows up in the table at the bottom.

Do I need a different SSD?


You need USB 2.0 and try again

Tried both USB 2.0 and 3.0 cables - still not recognized.

Gonna try a Samsung SSD…


Still no go with the Samsung SSD

Windows Disk Management recognizes the Argon 40 but it won’t show up in the flashing program.

Sooo frustrating and a deal breaker if I can’t get it working.


Just another data point. If I plug the SSD directly into one of the USB 3 ports it works great. It’s either the USB jumper or the Argon M.2 board that is failing…


I think the problem is the USB cable. Can you try other cable?

I think I’ve got it fixed, I bought the NVMe specific expansion board and the drive is recognized. There may be a compatability issue though as now my mouse/keyboard don’t work properly.

I thought the update was supposed to enable NVMe on the M.2 but, apparently, I was wrong.

I’ll get a SATA M.2 and try it in the original adpater. Fingers crossed!!


@Skibumwi did you manage to get it to work?

Yes, the SATA drive works flawlessly and the NvME drive works great plugged into a USB port.