Argon One M.2 booting issue

Hi

When I try to boot my pi after assembling in my new Argon One M.2 case with an SD card in, it powers on for a couple of seconds, the fan spins, and then nothing. No video output. I am using the official USB-C power supply. If I boot without SD, I get video output and see the bootloader screen, which confirms no SD card present. Then if I insert the SD card in, bootloader screen disappears and I lose video output again.

I have disassembled the case and confirmed that the Pi still boots from the same SD card when not plugged with the Argon case.

I have tried even after adding the command ‘hdmi_force_hotplug=1’ in config.txt file, still same result.
My case has the SSD sheild but as of now I’m trying without the ssd.

Could anyone help me to overcome this issue.

Thanks in advance !

Hey

I’m curently having the exact same issue as we speak. I’ve flashed the SD card a few times (tried a fresh 64-bit and 32-bit installation) but no change. I’ve tried Kali Linux 32-bit after that and it boots fine.

Curious, when you say you are using the official USB-C power supply, do you mean the official power supply that came with your raspberry pi (5.1V / 3.0A)?
I’m using a Samsung charger, with an output of 5.0V / 2.0A, which is too low, but it worked without the Argon case. I’ve read Argon One V2 needs a 5.25V / 3.5A power supply, so I’ve ordered one.

I’m not sure it’s the solution, but I’ll let you know after testing.

Hi

I’m using the official raspberry pi power supply 5.1V / 3.0A.

Thank you

Hi,

Which video output are you expecting ?

  • Analog ?
  • HDMI1 ?
  • HDMI2 ?

In standard PI4 distribs, i heard that analog composite is disabled by default.

Composite Video
Can be handled by boot loader with config.txt
On the Raspberry Pi 4, enable composite video. On models prior to the Raspberry Pi 4, composite video is enabled by default so this option is not displayed.

HDMI
You can also try to switch between the two HDMI output and it’s better to have screen appliance on before switch on the pi.

There is a set of HDMI settings in config.txt to force different modes depanding on your screen capabilities.
https://www.raspberrypi.com/documentation/computers/config_txt.html#video-options

MONITOR/TV
You can also try different screens if you have
4 weeks ago i failed using a scott tv “hd ready” with an old and odd hdmi protocol, i didn’t success using it at all neither with HDMI nor composite output with libreelec piOS.
I finally get a working machine with a standard raspbian from raspberry.org and a lot of patience (3 or 4 days of troubleshooting).
This hardware works like a charm with all others distros and HDMI devices i have tested (eg.: TV panasonic, Marantz HTPC receiver, standard DELL or Iiyama Monitors etc.)

Hope this can help you.

Tell us more

1 Like

I had a similar problem and it boiled down to a powering issue RPi4 to the M.2 board through USB3.
My doubt is that the RPi4 cannot deliver enough power. I used the Argon Power supply which has a bit higher current than the official RPi4 powersupply but still showed the problem.
I used a powered USB3 hub between RPi4 and the M.2 board and everything works fine.
Luckily I had to use a USB3 hub anyway since there are more USB3 devices connected.
I am not super happy with the solution but it works.

I use official :
RPI PS 15W BK EU Raspberry Pi - Alimentation, 5,1 V, 3,0 A
from reichelt store

No powering issue with more or less these 3 USB devices :

  • USB3 to USB SSD Case with [Crucial BX500 2TB] (choice for low power strategy)
  • USB2 to Rii 25 remote dongle
  • USB2 to USB Nuprime Dac

Official admitted USB cumulated load for raspberry pi4 is 1200mA, for all USB devices

You can check individual peripherals needs with a tools like this one :
https://www.jacobsparts.com/items/USBTESTER-A

and add all results to check either your are out or within limit of 1200 mA.

In my case :

  • SSD Crucial BX500 2TB : between 200 mA idle and 600 mA with high usage
  • Rii 25 remote dongle 10 mA
  • USB Nuprime Dac 500 mA

Total : 1110 mA
Status: near limit but OK

Just to confirm, but i think they already did, don’t connect any usb device at start to troubleshot video output issues

I have received the new power supply. The problem still persists.

I can SSH into the raspberry pi though and after editing the config file, I now do get HDMI output.

I’ve changed these settings in /boot/config.txt:
hdmi_group=1
hdmi_mode=75
config_hdmi_boost=7
dtoverlay=vc4-fkms-v3d

Note: vc4-fkms-v3d instead of vc4-kms-v3d

This seems to work, but I’m not sure which option is the one fixing the output yet. Will need to test further. Please check if these options give you screen output beyond the bootscreen.

1 Like

Hello

I’m able to view the output now. I don’t know it was a rookie mistake from my side or it’s the solution for my issue. I’ve done the following:

  1. Uncommented the command hdmi_force_hotplug=1 in the config.txt file.
  2. Plugged the HDMI cable to the port near to the type C power port.

Even I’m able to see the output without uncommenting the command but half of the task bar was not visible to me. The same is appearing correctly after uncommenting the command.

Let me know if the same is working for you guys

Thank you :slightly_smiling_face:

1 Like

You need to change the settings for a headless (no monitor connected) display.
I.e. I used following:

Force resolution of 1920x1080 even if no HDMI display is attached

hdmi_force_hotplug 1 Tells your Pi an HDMI display is attached.
hdmi_ignore_edid 0xa5000080 Ignores EDID/display data.
hdmi_group 2 Defines the HDMI output group.
hdmi_mode 16 Forces (for example) 1024x768 at 60Hz.
hdmi_mode 82 1920x1080 at 60Hz
hdmi_mode 36 1280x1024 at 75Hz

use only one of the hdmi_mode settings depending on the resolution you want.

1 Like

I’m having a similar problem, except I can’t ssh, it won’t connect to wifi, and nothing is working. I’ve tried several different operating systems, nothing seems to work. The pi was working just fine before I tried installing it. Now it will just light up and nothing happens.

Same issue here. No ssh possible after adding the M.2 case. Did buy the official Argon adapter no difference at all. Do anyone have a solution?

What os are you trying to use?
Okay so I found the argon one case does not like booting with the USB keyboard and mouse.
Unplug keyboard
Unplug mouse
Then try booting
I have found I had to reflash eeprom to the latest default
And if you try using Ubuntu you will need to edit the partition so it has the 4mb unformated at the beginning then the boot followed by the os.

Oh yeah I’m using a raspberry pi 4b 8gb overclocked at 2g and the official raspberry pi 5 pd

I no longer have to unplug my USB’s to boot up.

If your raspberry pi doesn’t get enough power it will not boot up. You will get some blinking lights then it just stays red. I recommend the raspberry pi 5 pd/ power supply.

If you don’t supply enough power your operating system will try and limit the systems it has running. So in theory the wifi could be disabled and cause system to freeze and hang on processes.

Hope this helps.