Argon M.2 SSD Boot Issues


Just bought this lovely case but cannot for the life of me get any OS to boot with the M.2. storage. Raspberian boot sequence starts, but I just get loads of complaints that it cannot find the boot drive.

The errors I get when loading are:
xHC-CMD err: 4 type: 11 [02:01 0.00 000002:01]

I have tried both Kingspec and WD Blue SSD M.2. drives. I have an offical Raspberry pi 5.1v /15w PSU, and have tried multiple OS’s. Booting from SD works great, booting from a 2.5 inch SSD with USB to SSD cable is fine (even in the case), and the M.2. Mini board works fine with my windows machine and I am not overclocking or any nonsense like that. I have trimmed some pins incase they were shorting - still no luck. I have tried updating the pi bootloader so it is now running - 2022-12-07 version.

Can anyone help give some advice?


did you update the bootloader?



Yep - second to last paragraph last sentence. Got the green screen after loading it and everything.

Going to return this. Believe I have done more than my fair amount of attempts to resolve this using the pi forum:

Shame - I really liked this case.

What is the model numbers of the m.2 sticks?

I’m not sure if this helps or not. I had a similar problem with the Pi not booting in the case and tracked it down to a faulty USB Bridge adaptor. I used a usb cable as a bridge and it worked fine. Using the Argon Bridge and it didn’t work. In the end I had to get a new bridge and it fixed the problem.